@keltik85 opened this Issue on April 4th 2016

My Piwik instance is not rendering the images in the Visitors Overview:

image

This is the Network access log of Chrome:

image

I already have done the following (edit config.ini.php, add disable_merged_assets ), but of no avail:

http://piwik.org/faq/troubleshooting/faq_135/

What else can I do?

@tsteur commented on April 4th 2016 Owner

Do you have access to the server logs?

@mattab commented on April 4th 2016 Owner
@keltik85 commented on April 5th 2016

Do you have access to the server logs?

Yes, and I have also activated the piwik.log like this: http://piwik.org/faq/troubleshooting/faq_115/ .

I can see the Piwik log like this, but its empty:

root<a class='mention' href='https://github.com/bb8b20685309'>@bb8b20685309</a>:/var/www/html# cat tmp/logs/piwik.log | grep ERROR
root<a class='mention' href='https://github.com/bb8b20685309'>@bb8b20685309</a>:/var/www/html#

To see the access and error log of apache I can do this:

[root<a class='mention' href='https://github.com/localhost'>@localhost</a> templates]# docker logs piwikcontainer | grep Error
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 172.17.0.4. Set the 'ServerName' directive globally to suppress this message
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 172.17.0.4. Set the 'ServerName' directive globally to suppress this message
[Tue Apr 05 06:17:22.297939 2016] [mpm_prefork:notice] [pid 1] AH00163: Apache/2.4.10 (Debian) PHP/5.6.19 configured -- resuming normal operations
[Tue Apr 05 06:17:22.297995 2016] [core:notice] [pid 1] AH00094: Command line: 'apache2 -D FOREGROUND'

See https://piwik.org/faq/troubleshooting/faq_34/

Thanks for the advice. I have installed the php5-gd library, but still the images dont, show up. My Dockerfile looks like this:

FROM php:5.6-apache
MAINTAINER "<max.payne<a class='mention' href='https://github.com/abc'>@abc</a>.org>"
COPY ./templates/apache2files/piwik /var/www/html/
COPY ./templates/php.ini /usr/local/etc/php/
RUN chmod 777 -R /var/www/html/
RUN docker-php-ext-install mysqli
RUN docker-php-ext-install mbstring
RUN apt-get update && \
         apt-get install -y php5-gd --no-install-recommends && \
         rm -r /var/lib/apt/lists/*


EDIT-1:
Although i installed the php5-gd extension, it is not loaded:

root<a class='mention' href='https://github.com/4ddd1ce105a6'>@4ddd1ce105a6</a>:/var/www/html# php -m
[PHP Modules]
Core
ctype
curl
date
dom
ereg
fileinfo
filter
hash
iconv
json
libxml
mbstring
mysqli
mysqlnd
openssl
pcre
PDO
pdo_sqlite
Phar
posix
readline
Reflection
session
SimpleXML
SPL
sqlite3
standard
tokenizer
xml
xmlreader
xmlwriter
zlib

[Zend Modules]

I think i have to post the issue on the php-docker Github page. (https://github.com/docker-library/php/issues/215)

This Issue was closed on April 5th 2016
Powered by GitHub Issue Mirror