@hpvd opened this Issue on February 8th 2016

Standard search & result finding process seems to be not trackable well:

  1. doing a search e.g. for "myword"
  2. results page opens "myword"
  3. use a filter e.g. "myfilter"
  4. follow one of the links to pages shown on result page

Visitor log shows only a second search for "myword"
Filter usage is not shown

2016-02-08_15h36_56

This is how url structure for this looks as an example within Magento:

searching for "myword"
...site.de/catalogsearch/result/?q=myword&cat=

and than applying a filter of name
"myfilter"

...site.de/catalogsearch/result/index/?cat=36&q=myword

("myfilter" is cat = categorie = 36)

this should be visible.

This is how setup looks:
2016-02-08_15h48_34

maybe there is simply a way to set it up in a better way?

@mattab commented on March 31st 2016 Owner

Hi @hpvd

do you mean that "Site Search Category" is not displayed in Visitor Log? If you confirm, we would be able to easily fix this issue.

@hpvd commented on March 31st 2016

yes (I think so, should fit decription above)

@sgiehl commented on April 25th 2016 Member

If a search category is set, it should be displayed on hover in the visitorlog.
Checked that by generating visits with VisitorGenerator plugin:
image

@romanoza commented on May 24th 2016

Is it possible to construct the filter (segment) based on the search category?

@mattab commented on May 27th 2016 Owner

Is it possible to construct the filter (segment) based on the search category?

@romanoza not yet possible, but it would be possible to add, could you create an issue for this new feature?

@mattab commented on May 27th 2016 Owner

If a search category is set, it should be displayed on hover in the visitorlog.

Cheers @sgiehl for checking. Closing as should already work.

This Issue was closed on May 27th 2016
Powered by GitHub Issue Mirror