@anonymous-piwik-user opened this issue on August 18th 2009

I have the same problem on 2 domains, hosted on the same server:

!http://slashte.de/piwik/ (older piwik version) and !http://fzsabstatt.de/piwik/ (piwik current version)

There is a similar failure message like "Declaration of Piwik_Event_Notification::increaseNotificationCount() should be compatible with that of Event_Notification::increaseNotificationCount()"

piwik was running on both domains a few days ago. PHP INFO: !http://fzsabstatt.de/piwik/phpinfo.php

@robocoder commented on August 18th 2009

The older piwik version at slashte.de has to be updated to the current version. In 0.4.1, we made changes to accommodate compat busters in PHP 5.2.10 (which your site is now running).

For fzsabstatt.de, the error message shows line numbers and function names that don't match up with the current version. That's a strong indicator that you have a mix of old and new files, i.e., an incomplete upgrade. Re-upload/install the latest Piwik version.

This issue was closed on August 18th 2009
Powered by GitHub Issue Mirror