Here it says "Continue to Piwik" but it is not clear what is happening here. Better would be maybe "Upgrade Database" but a user might have already upgraded the database manually (via Console or SQL statements). Maybe we should name it "Upgrade Piwik" (since there might be also other non-DB updates) or "Upgrade and continue to Piwik"
"Accept and Proceed"?
I don't mind adding the change if you like it
Thanks @Globulopolis, mattlab has answered that part with
we don't assign issues, you can just create a Pull Request and reference this one
What about "Finish updating" or "Finish Update"?