@robocoder opened this Issue on August 8th 2009 Contributor

The default char_set is ISO-8859-1. (Piwik does not currently specify/override this.)

Review usage of core/SmartyPlugins/modifier.escape.php. Force 'UTF-8' where necessary.

@robocoder commented on August 9th 2009 Contributor

ISO-8859-1 is 8-bit. UTF-8 multi-byte sequences have the high bit set. HTML special chars are in the ASCII (7-bit) range. So, it's not a problem.

However, in the review, found CorePluginsAdmin used the escape modifier on the plugin description. This causes anchor tags to not display properly.

@robocoder commented on August 9th 2009 Contributor

In [1379], don't use escape modifier when displaying plugin description.

This Issue was closed on August 9th 2009
Powered by GitHub Issue Mirror