@gbyers opened this Issue on August 20th 2015

Currently getting the following error in the times section under visitors in piwik "
Error: Key "1" for array with keys "0" does not exist in "@CoreVisualizations/_dataTableViz_tagCloud.twig" at line 1"

capture

@sgiehl commented on August 25th 2015 Member

Which version of Piwik are you using? I'm not able to reproduce that. Did you do anything spcial?

@gbyers commented on August 27th 2015

I'm using the latest version. The only thing I did was change dates to view
other parts of the year. Could something have happened under the sheer
amount of data?

On Tue, Aug 25, 2015 at 10:24 PM, Stefan Giehl notifications@github.com
wrote:

Which version of Piwik are you using? I'm not able to reproduce that. Did
you do anything spcial?


Reply to this email directly or view it on GitHub
https://github.com/piwik/piwik/issues/8614#issuecomment-134745889.

@mattab commented on September 19th 2015 Owner

@gbyers can you reproduce this issue on the demo.piwik.org ? if yes, how do you reproduce this issue?

@s1awa commented on November 14th 2016

I just got the same error with the latest piwik (even updated today to 2.17.1.).
Only one user is getting the error for all his tracked websites! Viewing same data logged in as another user (e.g. admin) works fine.
Affected user will get the error for 'Visitors - Times'. Changing dates and other tracked websites gives same error.

Error: Key "1" for array with keys "0" does not exist in "@CoreVisualizations/_dataTableViz_tagCloud.twig" at line 1

@tsteur commented on November 14th 2016 Owner

Can you maybe have a look at http://piwik.org/faq/troubleshooting/#faq_21433 ?

@s1awa commented on November 15th 2016

@tsteur Thanks, that fixed it.
Here are the values of the row I deleted:

option_name: 
viewDataTableParameters_iizi_VisitTime.getVisitInformationPerServerTime

option_value:
{"columns":["nb_visits"],"columns_to_display":["nb_visits"],"rows":[],"rows_to_display":[],"isFooterExpandedInDashboard":true,"viewDataTable":"cloud"}

autoload:
0

I don't know what the user did with view settings to recreate the issue. I hope the data above can help.

@tsteur commented on November 15th 2016 Owner

This would be maybe helpful in the future: https://github.com/piwik/piwik/issues/10795

Ideally we look into how this happens in the first place

Powered by GitHub Issue Mirror