@quba opened this issue on August 13th 2015

When I'm using --force-periods=day I'd expect that Piwik will archive only day period. Unfortunately that's not the case. Please see below:

INFO [2015-08-13 15:05:56] START
INFO [2015-08-13 15:05:56] Starting Piwik reports archiving...
INFO [2015-08-13 15:05:56] Will pre-process for website id = 2, period = day, date = last2
INFO [2015-08-13 15:05:56] - pre-processing all visits
INFO [2015-08-13 15:05:57] Archived website id = 2, period = day, 0 segments, 0 visits in last last2 days, 0 visits today, Time elapsed: 0.003s
INFO [2015-08-13 15:05:57] Will pre-process for website id = 2, period = range, date = last7
INFO [2015-08-13 15:05:57] - pre-processing all visits
INFO [2015-08-13 15:06:01] Archived website id = 2, period = range, 0 segments, 533 visits in last last7 ranges, 533 visits this range, Time elapsed: 3.388s
INFO [2015-08-13 15:06:01] Will pre-process for website id = 2, period = range, date = last30
INFO [2015-08-13 15:06:01] - pre-processing all visits
INFO [2015-08-13 15:06:06] Archived website id = 2, period = range, 0 segments, 2375 visits in last last30 ranges, 2375 visits this range, Time elapsed: 4.857s
INFO [2015-08-13 15:06:06] Will pre-process for website id = 2, period = range, date = previous30
INFO [2015-08-13 15:06:06] - pre-processing all visits
INFO [2015-08-13 15:06:09] Archived website id = 2, period = range, 0 segments, 2383 visits in last previous30 ranges, 2383 visits this range, Time elapsed: 2.873s
INFO [2015-08-13 15:06:09] Archived website id = 2, 4 API requests, Time elapsed: 12.631s [1/1 done]
INFO [2015-08-13 15:06:09] Done archiving!
This issue was closed on August 30th 2015
Powered by GitHub Issue Mirror