@tsteur opened this Pull Request on July 29th 2015 Owner

In #7323 we announced to drop support for PHP 5.3 in Piwik 3.0.

In this PR I changed to run the UI tests to PHP 5.4 as it is needed by PRs like this https://github.com/piwik/piwik/pull/8449 which requires PHP 5.4.

If someone knows what the lowest available PHP 5.4 version on Travis is, let me know. I couldn't find that information. Right now they will run on the latest PHP 5.4

I also removed some code in tests that marked tests as skipped if they run on PHP 5.3. This will be no longer needed.

If a super user is logged in, we currently show a message PHP 5.3 has reached EOL etc. I changed this to PHP 5.4 as it reaches soon EOL and by the time it will have reached for sure. I removed the message that we will drop support for PHP 5.4 though (as we won't do this for now).

@tsteur commented on July 29th 2015 Owner

Sorry, wanted to do a PR for Piwik 3.0, not master

This Pull Request was closed on July 29th 2015
Powered by GitHub Issue Mirror