@anonymous-piwik-user opened this Issue on June 28th 2009

After the update to 0.4.1 (from 0.4) i get the following error if i try to go to my piwik homepage:

the $compile_dir '/var/www/web151/html/_statistik.trumpkin.de//var/www/web151/phptmp/templates_c' does not exist, or is not a directory.

Backtrace:
#0 /var/www/web151/html/_statistik.trumpkin.de/libs/Smarty/internals/core.write_compiled_resource.php(20): Piwik_Smarty->trigger_error('the $compile_di...', 256)
#1 /var/www/web151/html/_statistik.trumpkin.de/libs/Smarty/Smarty.class.php(1451): smarty_core_write_compiled_resource(Array, Object(Piwik_Smarty))
#2 /var/www/web151/html/_statistik.trumpkin.de/libs/Smarty/Smarty.class.php(1281): Smarty->_compile_resource('CoreUpdater/tem...', '/var/www/web151...')
#3 /var/www/web151/html/_statistik.trumpkin.de/core/View.php(127): Smarty->fetch('CoreUpdater/tem...')
#4 /var/www/web151/html/_statistik.trumpkin.de/plugins/CoreUpdater/Controller.php(174): Piwik_View->render()
#5 /var/www/web151/html/_statistik.trumpkin.de/plugins/CoreUpdater/Controller.php(141): Piwik_CoreUpdater_Controller->doWelcomeUpdates(Array)
#6 /var/www/web151/html/_statistik.trumpkin.de/core/Piwik.php(924): Piwik_CoreUpdater_Controller->runUpdaterAndExit(Object(Piwik_Updater), Array)
#7 /var/www/web151/html/_statistik.trumpkin.de/core/FrontController.php(211): Piwik::displayScreenForCoreAndPluginsUpdatesIfNecessary()
#8 /var/www/web151/html/_statistik.trumpkin.de/index.php(57): Piwik_FrontController->init()
#9 {main}

Ciao!
Stefan

@robocoder commented on June 28th 2009 Contributor

For the record, what version of php?

@robocoder commented on June 28th 2009 Contributor

Are you overriding the compile_dir setting?

@robocoder commented on June 28th 2009 Contributor

compile_dir (and cache_dir) should be paths relative to the Piwik document root. I assume you changed:

compile_dir from "tmp/templates_c"
to: "/var/www/web151/phptmp/templates_c"

This should now be: "../../phptmp/templates_c"

@robocoder commented on June 28th 2009 Contributor

Or apply the patch in [1261]. Your override should be in config.ini.php to avoid being overwritten.

This Issue was closed on March 19th 2010
Powered by GitHub Issue Mirror