@andrzejewsky opened this Issue on June 29th 2015 Contributor

Hi, I found problem with visitor map, take a look on the screenshot:

zrzut ekranu 2015-06-29 o 17 10 00

Look at the console, we can see a lot of "NaN" errors. I think, this problem occur only if we will select Canada

@tsteur commented on June 29th 2015 Owner

Can you let us know what your browser + operating system is and steps to reproduce? Also what's your Piwik version?

@quba commented on June 29th 2015 Contributor

demo.piwik.org on Mac OS X using latest Chrome.

@mattab commented on July 1st 2015 Owner

Since we recently fixed some problems with the map, i'm wondering that maybe it will be fixed in RC2 (coming soon). Let's check bug is still here in RC2 once it will be on the demo.

@quba commented on July 6th 2015 Contributor

I can still reproduce it using demo.piwik.org (after update)

@barbushin commented on July 6th 2015 Contributor

Problem was in Kartograph centroid calculation function, it was a popular bug fixed in Kartograph v 0.8.2 (see https://github.com/kartograph/kartograph.js/blob/master/CHANGELOG.md#082).

There was some backward compatibility problem with Kartograph 0.8.6 and 0.8.7, so I just used 0.8.2 release with trivial migration refactoring. Now it works.

@mattab commented on July 7th 2015 Owner

Assigning to 2.14.1 to have bit more time to test it

@mattab commented on July 12th 2015 Owner

PR was reverted in #8335

This Issue was closed on July 14th 2015
Powered by GitHub Issue Mirror