@simpleuser99 opened this Issue on June 29th 2015

Hello everybody!
I have a trouble. The UserCountryMap plugin do not work. I see a white frame instead the map.
I have a next errors in my Firebag.
usercountrymap
How can i fix it?

@tsteur commented on June 29th 2015 Owner

Can you let us know what your browser + operating system is and steps to reproduce? Also what's your Piwik version?

@simpleuser99 commented on June 30th 2015

My browser is google chrome 43.0.2357.81 m and firefox 38.0.1
Operation system windows 7. My Piwik version is 2.13.1.
I have russian version of piwik, and i don`t know how it named in english version, but i try to explain with screenshot.
You may click 1 and 2 as well as in the attach screenshot.
piwik_explain

@simpleuser99 commented on July 3rd 2015

anybody help me?

@Globulopolis commented on July 3rd 2015 Contributor

@simpleuser99 try to setup force_ssl = 1 under the [General] section in config.ini.php. And you're using a self-signed certificate?

@simpleuser99 commented on July 3rd 2015

@Globulopolis i don't use ssl sertificate. I have rewrite http to https

@Globulopolis commented on July 3rd 2015 Contributor

@simpleuser99 don't do that, or you will get an errors about mixed content.

@simpleuser99 commented on July 3rd 2015

@Globulopolis . i`m sorry. I wrote wrong information in my last message. I use thawte-signed sertificate.

@diosmosis commented on July 3rd 2015 Member

@simpleuser99 Could you translate the error messages, maybe?

Also, if you try to load the page w/ the following INI config, you will get clearer stack traces:

[Development]
disable_merged_assets = 1

If you use it, be sure to undo your changes after you're done checking.

@simpleuser99 commented on July 6th 2015

@diosmosis
i try to translate line 4. "Blocked active content of mixed loading" or "activ mixed content loading is bloked"
I dont understand when the mistakes. Piwik plugin code has the mistakes or my install/settings has the mistakes. I use piwik during four months, and i didnt have trouble with UserCountryMap. I dont know when UserCountryMap did broken, but i can suppose that happend when i install last update piwik (2.13.1) but im not sure

@simpleuser99 commented on July 6th 2015

@mnapoli @mattab Could you help me with my problem?
I think that problem in code.

@tsteur commented on July 6th 2015 Owner

Do you mind sending us login credentials to your Piwik to "hello at piwik.org"? If so, please comment here after you sent it so we can check the spam folder just in case. A user having view access should be enough. Otherwise it will be hard for us to investigate further.

Also try to maybe deactivate all browser extensions in case you have any installed (eg adblocker) just in case.

@simpleuser99 commented on July 7th 2015

@tsteur I trying to use Piwik in IE11 without extensions and i view the issue.
I send login/pass to your email ( thomas@piwik.org)

@tsteur commented on July 8th 2015 Owner

I get the following error:

Mixed Content: The page at 'https://example.org/index.php?module=CoreHome&action=index&i…=UserCountryMap&action=realtimeWorldMap&idSite=4&period=day&date=yesterday' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http://example.org/plugins/UserCountryMap/svg/world.svg'. This request has been blocked; the content must be served over HTTPS.

It looks like svg maps are loaded via HTTP in your case (I can also see svgBase url is set to HTTP). This means most likely that this method returns a HTTP url for you: https://github.com/piwik/piwik/blob/2.14.0-rc3/core/SettingsPiwik.php#L166

This method should return a https url as I'm requesting the page with https. Somewhere there seems to be a bug. Maybe someone has an idea why this method would return not HTTPS when requested with HTTPS?

BTW: There seems something wrong with your installation. It is very slow and seems to regenerate the merged JavaScript quite often etc which takes always over a minute etc. Do you maybe use custom plugins?

@simpleuser99 commented on July 8th 2015

@tsteur I don`t understand this "It is very slow and seems to regenerate the merged JavaScript quite often etc which takes always over a minute etc." sentence, Can you explain me it more simple language?

I use standart plugins and the following plugins from piwik.org marketplace:
AdvancedCampaignReporting
ComparisonDashboard
InterSites
LiveTab
LoginLdap
PerformanceMonitor
TasksTimetable

@mattab commented on July 9th 2015 Owner

Maybe someone has an idea why this method would return not HTTPS when requested with HTTPS?

Could it be (yet another) occurrence of #6880 ?

@tsteur commented on July 13th 2015 Owner

This is actually a duplicate of https://github.com/piwik/piwik/issues/6703

I don`t understand this "It is very slow and seems to regenerate the merged JavaScript quite often etc which takes always over a minute etc."

Is Piwik fast for you? If not, you might want to create a question regarding this in the forum: http://forum.piwik.org/list.php?2

@simpleuser99 commented on October 16th 2015

I want to know when this issue will be resolved ?

@mattab commented on October 16th 2015 Owner
This Issue was closed on July 13th 2015
Powered by GitHub Issue Mirror