As documented in: http://forum.piwik.org/index.php?showtopic=1079
we would like to: - resolve inconsistency; probably all setX should "replace" the list of classes, except the piwik_* default css class should always be in the list. - update the documentation to make it a bit more clear
Should we rename the functions for consistency too?
yes it sounds like a good idea. what do you think about: - all functions accept either array or string names, or a simple string - all function named setBlahClasses() - we keep the old functions as briges and call the new ones - for backward compatbility for 0.4 users that already use the API
(In ) refs #816 - added setDownloadClasses() and setLinkClasses() for consistency with setIgnoreClasses(), refactoring, and additional tests