@larsen0815 opened this issue on April 17th 2015

I´ve found this in my php.log:

Error in Piwik (tracker): An unexpected website was found, check idSite in the request.

Please add the value of idSite to the log entry. How else could I find out which idSite is causing this?

@mattab commented on April 20th 2015

Hi @larsen0815 what version of Piwik are you using and do you have the URL used to reproduce the issue?

@larsen0815 commented on April 20th 2015

Hi @mattab version is 2.8.3. URL is unknown as I don´t have the id in the log.

@mattab commented on April 21st 2015

Hi @larsen0815

can you upgrade to Piwik 2.12.1 ( I think this bug was fixed.)

if you still have the problem with 2.12.1 please leave a comment

@larsen0815 commented on May 5th 2015

Upgraded to 2.13.0 yesterday. Today I still have the same errors in my log.

@larsen0815 commented on August 4th 2015

Thx, I was able to find out the website now. Though, I was lucky to have an old instance of the database where the site was still in. It would be good when sites that get deleted are either only flagged as deleted (without actually deleting the record) or moved into another table like "site_deleted".

@mattab: May I open a new issue for that?

@larsen0815 commented on August 7th 2015

Would it be possible to log the referrer so you can see which domain is responsible for the log entries?

@mattab commented on August 10th 2015

@larsen0815 can you please create a new issue for this request (this issue is closed)?

This issue was closed on July 14th 2015
Powered by GitHub Issue Mirror