@anonymous-piwik-user opened this Issue on June 6th 2009

It seems, that the value of the flash export field is not escaped correctly and so the value is not completly in the input field.

Example in 0.2.37 VisitsSummary->Overview

<label for="embedThisWidgetFlashInput"> Embed Flash</label><span id="embedThisWidgetFlashInput"><input class="formEmbedCode" id="flashEmbed" value="<object style="visibility: visible;" id="VisitsSummarygetEvolutionGraphChart_swf" data="/typo3conf/ext/piwikintegration/piwik/libs/open-flash-chart/open-flash-chart.swf" bgcolor="#FFFFFF" type="application/x-shockwave-flash" height="150" width="100%"><param value="sameDomain" name="allowScriptAccess"><param value="opaque" name="wmode"><param value="data-file=http%3A%2F%2Fwww.jrk-dresden.de%2Ftypo3conf%2Fext%2Fpiwikintegration%2Fpiwik%2Findex.php%3Fmodule%3DVisitsSummary%26action%3DgetEvolutionGraph%26columns%5B%5D%3Dnb_visits%26idSite%3D5%26period%3Dweek%26date%3D2008-11-10%2C2009-06-07%26viewDataTable%3DgenerateDataChartEvolution&loading=Loading..." name="flashvars"></object>

<div id="dataTableFeatures">
<div>
<span id="dataTableFooterIcons">
<span id="exportToFormat" style="display: none; padding-left: 4px;">
<span id="dataTableFooterExportAsImageIcon">
<a href="javascript:OFC.jquery.popup(" visitssummarygetevolutiongraphchart_swf="" );=""><img title="Export as Image" src="http://www.jrk-dresden.de/typo3conf/ext/piwikintegration/piwik/themes/default/images/image.png">
</span>
<img src="http://www.jrk-dresden.de/typo3conf/ext/piwikintegration/piwik/themes/default/images/export.png" title="Export" height="16" width="16">
<span id="linksExportToFormat" style="display: none;">
<a href="?module=API&method=VisitsSummary.get&format=CSV&idSite=5&period=week&date=2008-11-10,2009-06-07&token_auth=&filter_limit=100" target="_blank" class="exportToFormat" methodtocall="VisitsSummary.get" format="CSV" filter_limit="100">CSV</a> |
<a href="?module=API&method=VisitsSummary.get&format=XML&idSite=5&period=week&date=2008-11-10,2009-06-07&token_auth=&filter_limit=100" target="_blank" class="exportToFormat" methodtocall="VisitsSummary.get" format="XML" filter_limit="100">XML</a> |

<a href="?module=API&method=VisitsSummary.get&format=JSON&idSite=5&period=week&date=2008-11-10,2009-06-07&token_auth=&filter_limit=100" target="_blank" class="exportToFormat" methodtocall="VisitsSummary.get" format="JSON" filter_limit="100">Json</a> |
<a href="?module=API&method=VisitsSummary.get&format=PHP&idSite=5&period=week&date=2008-11-10,2009-06-07&token_auth=&filter_limit=100" target="_blank" class="exportToFormat" methodtocall="VisitsSummary.get" format="PHP" filter_limit="100">Php</a> |
<a href="?module=API&method=VisitsSummary.get&format=RSS&idSite=5&period=week&date=last10&token_auth=&filter_limit=100" target="_blank" class="exportToFormat" methodtocall="VisitsSummary.get" format="RSS" filter_limit="100" date="last10"><img src="http://www.jrk-dresden.de/typo3conf/ext/piwikintegration/piwik/themes/default/images/feed.png" border="0"></a>
</span>

<span id="dataTableFooterIconsShow" style="padding-left: 4px;">
<img src="http://www.jrk-dresden.de/typo3conf/ext/piwikintegration/piwik/plugins/CoreHome/templates/images/more.png">
</span>

</div>
<span id="loadingDataTable"><img src="http://www.jrk-dresden.de/typo3conf/ext/piwikintegration/piwik/themes/default/images/loading-blue.gif"> Lade Daten...</span>

<div class="dataTableSpacer"></div>

' onclick="javascript:document.getElementById('flashEmbed').focus();document.getElementById('flashEmbed').select();" readonly="true" type="text"&gt

@anonymous-piwik-user commented on June 6th 2009

Attachment: screenshot
piwik.png

@robocoder commented on June 6th 2009 Contributor

Should already be fixed in 0.4RC3.

This Issue was closed on June 6th 2009
Powered by GitHub Issue Mirror