@anonymous-piwik-user opened this issue on May 8th 2009

When I'm passing the campaign parameter as second parameter, it is not correctly detected. Thus, after setting

campaign_var_name = "cm"

in config.ini.php, the following doesn't generate a campaign record:

!http://my.test.domain/?x=0&cm=test&b=1

while this one works:

!http://my.test.domain/?cm=test&b=1

Keywords: campaign

@mattab commented on May 18th 2009

please read: Visits from search engines or campaigns are not recorded, Piwik shows "No data available".

especially the part where it explains that only the first keyword/campaign will be recorded as referer; can you please double check that you were not testing this way?

@anonymous-piwik-user commented on May 20th 2009

Hi, there. I checked again. The visitors are all coming with URLs of the typehttp://my.test.domain/page?q=keyword&cm=campaignname and the visits and urls are correctly recorded (they appear in the "page" reports, including the "q" and "cm" parameters), but the campaign names are never recorded.

When I visit the URLhttp://my.test.domain/page?cm=testcampaign instead, the campaign is recorded and appears in the administration interface.

I still think the different behaviour depends on the campaign parameter appearing as the first one or not. Could anyone check whether this is the case?

@mattab commented on May 30th 2009

did you check with at least 30 minutes between each test? if yes we shall reopen and fix this issue

@anonymous-piwik-user commented on June 16th 2009

Hi. We did some extensive testing and we are using piwik on a production website receiving lots of daily visits of the form !http://my.test.domain/page?q=keyword&cm=campaignname

Test visits where we use cm as first parameter are recorded, the ones with cm as second parameter are not. We installed the latest version yesterday and the issue seems to be still there.

Thanks

@robocoder commented on June 16th 2009

re-opening for investigation

@robocoder commented on June 16th 2009

By visual inspection of the code: piwik.js already escapes the url=XXX; in Tracker/Visit.php, getReferrerInformation() calls getRequestVar('url') which results in the value being sanitized. The result is confusing parse_url().

@robocoder commented on June 16th 2009

(In [1234]) fix #697 - some campaigns not being tracked

@mattab commented on April 27th 2011

see also - See new Tracking Campaigns - URL Builder tool - Official piwik campaign parameters names are now: pk_campaign and pk_kwd (consistent with cookie prefix, better than piwik_ prefix) - New FAQ: "Does Piwik support Google Analytics campaign parameters (utm_campaign, utm_medium, utm_source, utm_term)?" - New FAQ: "How do I customize the Piwik Campaign parameters pk_campaign and pk_kwd?"

This issue was closed on April 27th 2011
Powered by GitHub Issue Mirror