@purecanuck opened this Issue on January 6th 2015

I just updated to Piwik version 2.10.0 by unziping the zipfile, moving my config file into it, and then clearing the cache via php on the command line.

When I go to $URL/index.php?module=MultiSites&action=index&idSite=5&period=day&date=today

I get error message:
API returned an error: Sequence 'piwik_archive_numeric_2015_01' not found. at Sequence.php:99

@mattab commented on January 6th 2015 Owner

Hi there,

to fix this issue you can execute the Mysql QUERY:

INSERT INTO piwik_sequence (name, value) VALUES ('piwik_archive_numeric_2015_01' , 99999)
@sgiehl commented on January 6th 2015 Member

Similar issues were repoted on the forum more than once.

Couldn't we simply create the sequence when it isn't found but should be
there?

@mattab commented on January 6th 2015 Owner

see #6815

reason we didnt so far put a workaround is because it's a one-off issue, only heappen when old users upgrade, and in quite particular edge case...

@sgiehl commented on January 6th 2015 Member

IIRC there was one on the german forum having the issue after upgrading
from 2.9.1 to 2.10

@amq commented on February 5th 2015

I am experiencing the same issue - the insert fixed it for January, but now it is back. Will I have to run the insert each month?

Piwik 2.10.0, always upgraded from dashboard (no manual stuff like ftp uploads, mysql schema upgrades etc).

@purecanuck commented on February 11th 2015

mysql> INSERT INTO piwik_sequence (name, value) VALUES ('piwik_archive_numeric_2015_01' , 99999);
ERROR 1062 (23000): Duplicate entry 'piwik_archive_numeric_2015_01' for key 'PRIMARY'

@purecanuck commented on February 18th 2015

I'm still getting this issue after upgrading to Piwik 2.11.

@purecanuck commented on February 25th 2015

Let me know if there's any more information I can provide.

@mattab commented on February 25th 2015 Owner

We need to do something about this bug, adding Major tag

@mattab commented on February 26th 2015 Owner

@tsteur maybe you have an idea how we could fix this one in a proper way?

@pfmoser commented on March 1st 2015

New month, new luck. All my APIs requests from WordPress did have the error for the new month.

INSERT INTO piwik_sequence (name, value) VALUES ('piwik_archive_numeric_2015_03' , 99999)

did solve the problem for now, but I did a regular update via Dashboard and nothing in special. Please fix this before the next month. Thanks.

@mattab commented on March 2nd 2015 Owner
This Issue was closed on March 2nd 2015
Powered by GitHub Issue Mirror