@mnapoli opened this issue on November 11th 2014

Currently we have: - UnitTests - IntegrationTests - SystemTests

But in ./console tests:run we give unit, integration or system as shortcuts, which is confusing when using both the console and PHPUnit.

So how about renaming them to unit, integration and system?

@mattab commented on November 11th 2014

+1 to rename the suites as defined in https://github.com/piwik/piwik/issues/6634

@tsteur commented on November 13th 2014

Just FYI: We'll also have to update all the other repositories like https://github.com/piwik/piwik-tests-plugins/blob/master/.travis.yml and https://github.com/piwik/piwik-marketplace/blob/master/templates/common/travis.yml.twig . There might be many more usages. Not sure about travis yml files of plugin developers (not talking about Piwik or Piwik PRO where we might update the generated .travis.yml automatically etc). That's why I kept the testsuite CoreTests and PluginTests to stay kinda backwards compatible

@mnapoli commented on November 13th 2014

@tsteur thanks for the heads up, this is much bigger than I thought, I'm removing my branch for now maybe I'll feel more adventurous later ;)

@tsteur commented on November 13th 2014

You can otherwise search for the terms "UnitTests", "PluginTests", "IntegrationTests", "SystemTests" and "CoreTests" like this https://github.com/search?l=&q=PluginTests+user%3APiwik+user%3APiwikPro&ref=advsearch&type=Code&utf8=%E2%9C%93

Re plugin developers we can maybe simply make a notice in the changelog. I'm not really sure how it works there anyway

This issue was closed on May 30th 2016
Powered by GitHub Issue Mirror