@mnapoli opened this Issue on November 4th 2014 Member

As reported on a StackOverflow question, Piwik complains that PHP 5.3.3 is not greater than required PHP 5.3.3.

Here is the comparison function:

$piwik_minimumPHPVersion = '5.3.3';
$piwik_currentPHPVersion = PHP_VERSION;
$minimumPhpInvalid = version_compare($piwik_minimumPHPVersion, $piwik_currentPHPVersion) > 0;

version_compare will return 0 if both versions are equal, which explains it I guess. Easy fix would be to replace > by >=: I will do it soon.

@peterbo commented on November 12th 2014 Contributor

Why was this reverted?

@mnapoli commented on November 12th 2014 Member

Because I thought it was this bit of code but it wasn't ;) It was actually fixed in https://github.com/piwik/piwik/commit/f5c50e02dcc6df8fb349528daec9b2d70d898305

This Issue was closed on November 4th 2014
Powered by GitHub Issue Mirror