@integrationtester opened this Issue on October 27th 2014

while trying to fetch transitions on the newest piwik version (2.8.3) i get

There's no data for http:​/​/base url/​Gene Full Report Records

Either the action had no pageviews during the period
or it is invalid.
Go back to the previous action

when i click on a transition report in either the pages, or entry pages widget.

looking into it a bit more, the request:

http://piwik_url/index.php?date=2014-10-26&actionType=url&actionName=http%3A%2F%2Fbase_url%2FGene+Full+Report+Records&expanded=1&format=JSON&module=API&method=Transitions.getTransitionsForAction&idSite=1&period=day

results in
{"result":"error","message":"NoDataForAction"}

/////

it seems that there is an escaping issue here. if i naively escape my url (just needs spaces) here:

plugins/Transitions/API.php

137                 if ($id < 0) {
138                     $escapedPath = str_replace(" ","%20",$actionName);
139                     $id = TableLogAction::getIdActionFromSegment($escapedPath, 'idaction_url', SegmentExpression::MATCH_EQUAL, 'pageUrl');
140                 }  

then deriveIdAction succeeds (although the fetch still fails in addInternalReferrers farther down the road, i haven't continued to look into it.)

here is what the url looks like in mysql:

mysql> SELECT idaction, type, name FROM piwik_log_action limit 100
-> ;
+----------+------+-----------------------------------------------------------------------------------+
| idaction | type | name |
+----------+------+-----------------------------------------------------------------------------------+
...
| 3 | 1 | base_url/Gene%20Full%20Report%20Records

@mattab commented on October 28th 2014 Owner

Thanks for the report!

Can you reproduce this problem on the demo.piwik.org ?

Also maybe your bug is similar to an existing report see for example #4815 or #3609 or #4595 - please post in the related ticket if possible (with steps to reproduce the issue)

@integrationtester commented on October 28th 2014

i would assume all you need to reproduce this on demo.piwik.org is to have a url that has escaped spaces '%20', but i don't see any page urls with such a condition

@mattab commented on October 28th 2014 Owner

@integrationtester maybe you can generate such page URL on forum.piwik.org then you can see the stats in: http://demo.piwik.org/

if you can reproduce the issue this way, can you send me the link and information?

@integrationtester commented on October 30th 2014

looked into this, but the forum just uses ids for the urls, the titles aren't present in the url at all.

@integrationtester commented on October 30th 2014

also it might be worth noting that i am populating piwik using the bulk tracking api

This Issue was closed on October 28th 2014
Powered by GitHub Issue Mirror