@mattab opened this issue on October 21st 2014

Goal of this issue is to solve this bug and make sure it does not occur again.

Bug #4706 is back and can be reproduced on the demo.piwik.org archive log:

ERROR CoreConsole[2014-10-20 23:58:40] [7c2f9] Got invalid response from API request: http://demo.piwik.org/index.php?module=API&method=CoreAdminHome.runScheduledTasks&format=csv&convertToUnicode=0&token_auth=XXX&trigger=archivephp. 

Response was 'task,output Piwik\Plugins\CustomAlerts\CustomAlerts.runAlertsDaily_1,Time elapsed: 11.839s Piwik\Plugins\CustomAlerts\CustomAlerts.runAlertsDaily_16,Time elapsed: 0.010s Piwik\Plugins\CustomAlerts\CustomAlerts.runAlertsWeekly_1,Time elapsed: 0.054s Piwik\Plugins\CustomAlerts\CustomAlerts.runAlertsWeekly_16,Time elapsed: 0.059s Piwik\Plugins\ScheduledReports\API.sendReport_24,Time elapsed: 0.362s Piwik\Plugins\ScheduledReports\API.sendReport_25,Time elapsed: 2.230s Piwik\Plugins\ScheduledReports\API.sendReport_3,Time elapsed: 1.190s Piwik\Plugins\ScheduledReports\API.sendReport_7,

"ERROR: API returned an error: Trying to add two strings in DataTable\Row::sumRowArray: '7.01%' + '7.12%' for row # ['label' => 'Unknown', 'nb_visits' => 9654, 'nb_actions' => 26944, 'max_actions' => 86, 'sum_visit_length' => 2034922, 'bounce_count' => 4705, 'nb_visits_converted' => 677, 'sum_daily_nb_uniq_visitors' => 8242, 'sum_daily_nb_users' => 0, 'conversion_rate' => '7.01%', 'nb_actions_per_visit' => 2.79, 'avg_time_on_site' => 211, 'bounce_rate' => '48.83%'] ['url' => ] [idsubtable = ]<br />  at Row.php:644 " 

Piwik\Plugins\ScheduledReports\API.sendReport_5,Time elapsed: 0.619s Piwik\Plugins\ScheduledReports\API.sendReport_6,"ERROR: API returned an error: Trying to add two strings in DataTable\Row::sumRowArray: '8.78%' + '15%' for row # ['label' => 'Unknown', 'nb_uniq_visitors' => 449, 'nb_visits' => 521, 'nb_actions' => 1284, 'nb_users' => 0, 'max_actions' => 29, 'sum_visit_length' => 85272, 'bounce_count' => 274, 'nb_visits_converted' => 47, 'conversion_rate' => '8.78%', 'nb_actions_per_visit' => 2.47, 'avg_time_on_site' => 162, 'bounce_rate' => '52.89%'] ['url' => ] [idsubtable = ]<br />  at Row.php:644 " Piwik\Plugins\ScheduledReports\API.sendReport_37,Time elapsed: 0.062s Piwik\Plugins\ScheduledReports\API.sendReport_9,Time elapsed: 0.209s Piwik\Plugins\ScheduledReports\API.sendReport_13,Time elapsed: 0.578s Piwik\Plugins\ScheduledReports\API.sendReport_14,Time elapsed: 0.960s Piwik\Plugins\ScheduledReports\API.sendReport_15,Time elapsed: 1.412s Piwik\Plugins\ScheduledReports\API.sendReport_18,Time elapsed: 0.530s Piwik\Plugins\ScheduledReports\API.sendReport_21,Time elapsed: 0.062s Piwik\Plugins\ScheduledReports\API.sendReport_35,Time elapsed: 2.292s'
@mattab commented on October 22nd 2014

Waiting for #6261 to be closed which should also fix this bug.

@mygithuber commented on October 22nd 2014

There seems to be a similar bug if "Provider" is checked while generating reports in Piwik-2.8.1 pls look at: http://forum.piwik.org/read.php?2,121122,121144

@mattab commented on October 23rd 2014

This occurs very frequently since Piwik 2.8.0. Maybe we should fix even before 2.9.0?

@diosmosis commented on October 23rd 2014

It's a pretty big change, probably won't be ready until 2.9.

@mattab commented on October 23rd 2014

Temporary workaround: If you experience this issue, try remove the "Provider" report from scheduled reports. The bug should then appear much less often.

@quba commented on October 29th 2014

+1 to fixing this in 2.9 because this error appears really often recently (especially with custom plugins installed)

@mgazdzik commented on October 29th 2014

+1 to fix this

This issue was closed on November 11th 2014
Powered by GitHub Issue Mirror