@DaSchTour opened this Issue on October 15th 2014 Contributor

PHP 5.3.2 is a widely used version of PHP, simply because many Servers use Ubuntu 10.04 LTS. I'm sure there are many users like me, that have to wait for changing to another system. Since Ubuntu 10.04 LTS is supported till next year, It's really annoying, that there is a critical update, with security fixes, that doesn't work on this widely used Linux version!
And using a third-party PHP repository is not a solution! There are a lot of reason why using third-party PHP repositories is a bad as not supporting PHP 5.3.2 anymore.
As a user of open source software it's really frustrating that developers bush the requirements of their software forward faster and faster, so that I can't keep up with upgrading my server. I guess it's even a reason why in business environments I often hear: "This software runs with PHP? So we will not use it! There are too much problems with PHP."
And now we have next reason why PHP remain a script kiddy language and statistics will be done with Google and Adobe. I guess there will be no more web project I'll every suggest to use piwik for statistics. There are too much issues with updating.

@tsteur commented on October 15th 2014 Owner

If I remember correct the idea for 5.3.2 users was that it is still possible to update manually by downloading latest.zip from website, extracting the files and copying them to the server see http://piwik.org/docs/update/#the-manual-three-step-update .

I don't know what kind of problem was with 5.3.2 but I think it is very minor or would not affect many people. Maybe someone else can help me out? Please note: In one of the next versions we might include a library that requires 5.3.3 and don't know if Piwik will still work on 5.3.2 then. Might be a could idea to announce this upfront so people can upgrade upfront (if possible) or at least plan an upgrade.

@sgiehl commented on October 15th 2014 Member

IIRC the last problem occuring was some json related stuff. See https://github.com/piwik/piwik/issues/6390

@DaSchTour commented on October 16th 2014 Contributor

I already have planed upgrading my server, but start for rollout of Ubuntu 14.04 LTS is end of this or begin of last year. So I'll have to stay around 3 months on a vulnerable system :(

@mattab commented on October 16th 2014 Owner

upgrading to latest Piwik as this is quite important step because it's critical release.

As a workaround, to allow Piwik to run on 5.3.2 simply edit this line in Piwik 2.8.0: https://github.com/piwik/piwik/blob/master/core/testMinimumPhpVersion.php#L19-19

Please comment here if you experience the same issue.

@mattab commented on October 17th 2014 Owner

PHP-DI requires 5.3.3 so I guess we will soon really need it anyway #4917

@tsteur commented on November 10th 2014 Owner

I'll close it for now. Feel free to reopen at any time. If someone wants to use Piwik with 5.3.2 you can still upgrade manually by following the above mentioned workaround.

This Issue was closed on November 10th 2014
Powered by GitHub Issue Mirror