@alphaonex86 opened this issue on October 13th 2014

Hello,

I reopen my bug, here since years...: http://files.first-world.info/temp/screenshot-piwik.png

Cheers,

@nlsrchtr commented on October 15th 2014

Same here, more information below and in this screenshot:

Uncaught TypeError: undefined is not a function
  $.extend.reloadAjaxDataTable
  (anonymous function)
  n.event.dispatch
  r.handle

Uncaught TypeError: Cannot read property 'unbind' of undefined
  closeForm
  (anonymous function)
  n.event.dispatch
  r.handle

This happens in Chrome and Firefox. No data entry of the selected table will show up at all.

@tsteur commented on October 15th 2014

I think it should be fixed now but I cannot reproduce the problem. Can you maybe let me know the exact steps to reproduce this issue? Otherwise maybe you can apply this patch 03bad4b ? You might have to clear browser cache to test it.

@nlsrchtr commented on October 16th 2014

@tsteur, thanks for looking into this issue! Sadly your fix doesn't help. The steps to reproduce the issue are quite easy: go to the widget listing the external websites linking to the tracked project, click on one item in the list-view. Maybe this screenshot explains it better?

@tsteur commented on October 16th 2014

I can still not reproduce it :( Tried latest Chrome and Firefox. Are you doing anything before like selecting a segment or so? When you expand the error messages by clicking on the arrow do you get the same message as reported initially?

Can you maybe add the following section in your config/config.ini.php?

[Development]
disable_merged_assets = 1

and reload the page? Do you still get the same error? Does it maybe tell you in which file and/or line the error occurs? Once you've tried this I recommend to remove the config entry again.

@alphaonex86 commented on October 16th 2014

Yes, and same resolution, comment the line: $('#loadingError').hide();if(self.param.viewDataTable&&self.param.viewDataTable.indexOf('graph')===0){delete self.param.filter_offset;delete self.param.filter_limit;} disable_merged_assets -> unmerge correctly the assert, but same bug... dataTable.js line 215

@alphaonex86 commented on October 16th 2014

I come from piwik <1, when it was 0.X... I presume it's module order the problem: http://files.first-world.info/temp/config.txt Sort the array can prevent that's. And uniform the results...

@tsteur commented on October 16th 2014

Ok made another change but not sure if it fixes the issue as I can still not reproduce it even when changing module order. I cannot really imagine how a function undefined error can happen there but one never knows. I think we are maybe also talking about different/multiple JS errors here.

If it still does not work can you send us maybe your tmp/assets/asset_manager_core_js.js via email to hello at piwik.org ? Maybe in this folder is also another asset_manager_*_.js file? If so please send as well.

@alphaonex86 commented on October 16th 2014

Into tmp/assets/: archive_blob_2014_10-678ed2535d7addb4a6c51a9c5081ae4e.csv asset_manager_global_css.css asset_manager_global_css.css.deflate asset_manager_global_css.css.gz

@tsteur commented on October 16th 2014

There should be one or two *.js files? At least if you have removed the other config entry again. If not, try to access Piwik after removing the config entry and it should be created. Otherwise there might be a folder $yourhostname/assets/

@alphaonex86 commented on October 16th 2014

No .js found. I don't understand, I have the config file send more few other. ls tmp/assets/ asset_manager_core_js.js asset_manager_core_js.js.deflate asset_manager_global_css.css asset_manager_global_css.css.deflate asset_manager_non_core_js.js asset_manager_non_core_js.js.deflate After remove the config key. The content of all my folder: http://files.first-world.info/temp/assets.tar.xz

@tsteur commented on October 17th 2014

I will try to provide a fix later but it looks like it is related to the not loaded/enabled Insights plugin.

@tsteur commented on October 17th 2014

Ok I thought I can reproduce the issue but I can't. I got the previous error only because I had the Insights plugin enabled but used your JavaScript where it was not enabled. This time I also enabled some other plugins you are using but I do not have access to some plugins such as TidyUrl or SearchEnginePosition. At least I did not find them in the Marketplace. Not sure what to do next. Can you give us maybe access to your Piwik instance? A user with view permission would be enough. If so, please send us credentials to hello at piwik.org

@tsteur commented on October 17th 2014

FYI: If someone has this issue just remove the user country map widgets from the dashboard this should fix it until we have a fix.

@tsteur commented on October 17th 2014

Pull request to fix it in the chroma lib https://github.com/gka/chroma.js/pull/33 @gka maybe you can have a look?

@alphaonex86 commented on October 17th 2014

File not file with current version, and I need country map widgets

@nlsrchtr commented on October 17th 2014

@tsteur thanks for looking into this. On my side I have no differences in the behavior after removing the country-listing on the dashboard. So this doesn't seem to fix it on my side.

Do you still need access to one instance with this bug or did @alphaonex86 already provided you one?

@alphaonex86 commented on October 17th 2014

I have just removed the access, because don't seam more needed. If again needed just ask.

@mattab commented on October 20th 2014

Hi guys, please try again with the latest beta 2.8.1-b2 After upgrading can you still reproduce the issue? in one browser only (which one), or several browsers?

@nlsrchtr commented on October 20th 2014

Hi @mattab, I installed the latest beta and it works perfect. Thanks for your awesome work!

@mattab commented on October 20th 2014

Kuddos to @tsteur he's the ninja debugger for that one!

This issue was closed on October 20th 2014
Powered by GitHub Issue Mirror