@mnapoli opened this Pull Request on October 7th 2014 Member

I have refactored the code a bit to make it (hopefully) more readable.

The diff is going crazy, but basically I have just replaced this:

if (self::manageEvent($reportType)) {
    // big block of code
}

By this:

if (! self::manageEvent($reportType)) {
    return;
}

// big block of code

It's not much but it removes one level of indentation in almost the whole class (almost all the methods were like that), which is kind of nice.

(by the way this is one of the "object calisthenics" rules)

@mattab commented on October 8th 2014 Owner

Nice change improving readability!

This Pull Request was closed on October 8th 2014
Powered by GitHub Issue Mirror