@anonymous-piwik-user opened this Issue on March 26th 2009

After Upgrade to the lasted versions, i get a lot of this error messages:

Warning: require_once(Zend/Registry.php) [function.require-once]: failed to open stream: No such file or directory in mydomain.ch/subdomains/piwik/httpdocs/core/ErrorHandler.php on line 12

Fatal error: require_once() [function.require]: Failed opening required 'Zend/Registry.php' (include_path='.:.:') in mydomain.ch/subdomains/piwik/httpdocs/core/ErrorHandler.php on line 12

All files are existing and new upload with no success.

@mattab commented on March 29th 2009 Owner

was it working before the upgrade to the new version? can you try to apply this patch and go to piwik/ and copy paste what is shown on screen (either "false" or the string of include path)

Index: index.php
===================================================================
--- index.php   (revision 1035)
+++ index.php   (working copy)
@@ -17,11 +17,12 @@
    define('PIWIK_INCLUDE_PATH', dirname(__FILE__));
 }

-set_include_path(PIWIK_INCLUDE_PATH 
+$success = set_include_path(PIWIK_INCLUDE_PATH 
                    . PATH_SEPARATOR . PIWIK_INCLUDE_PATH . '/libs/'
                    . PATH_SEPARATOR . PIWIK_INCLUDE_PATH . '/plugins/'
                    . PATH_SEPARATOR . PIWIK_INCLUDE_PATH . '/core/'
                    . PATH_SEPARATOR . get_include_path());
+var_dump($success);exit;

 require_once "core/testMinimumPhpVersion.php";
@robocoder commented on April 25th 2009 Contributor

ping

@anonymous-piwik-user commented on April 26th 2009

I applied that patch now as I have exactly the same problem with the latest.zip (downloaded today, april 26 2009).

The output is now: bool(false)

In case you need to know more about my server config. Here's where I try to run it: http://repogen.simplylinux.ch/phpinfo.php (and here the patched index: http://repogen.simplylinux.ch/piwik/index.php )

@robocoder commented on April 26th 2009 Contributor

If you set the php include path in your apache configuration or .htaccess, piwik cannot set it.

@anonymous-piwik-user commented on April 26th 2009

??? I don't understand what you mean.

@robocoder commented on April 26th 2009 Contributor

Your phpinfo indicates that you have locally overridden the master php.ini value for include_dir.

If you can't see this in your Apache configuration, check your .htaccess files. These are applied recursively to subdirectories, so you you should check your piwik folder and parent folders.

@anonymous-piwik-user commented on April 26th 2009

There's nothing there that overrides anything now. I did include the path in the master because by default there is a "." as include. I have no idea how to take that out.

@robocoder commented on April 26th 2009 Contributor

My guess is that you would comment out the line.

@anonymous-piwik-user commented on April 26th 2009

Hmmm, I added now those three dirs manually to the include path in confixx.

The include path in phpinfo shows now as:

.:/usr/share/php:/var/www/web30/html/piwik/libs:/var/www/web30/html/piwik/plugins:/var/www/web30/html/piwik/core

However now I get this error:

Fatal error: Class 'Piwik_Common' not found in /var/www/web30/html/piwik/core/Piwik.php on line 98

@robocoder commented on April 26th 2009 Contributor

You're missing the piwik root directory.

@anonymous-piwik-user commented on April 26th 2009

Well, added the piwik root directory and it looks now like:

.:/usr/share/php:/var/www/web30/html/piwik:/var/www/web30/html/piwik/libs:/var/www/web30/html/piwik/plugins:/var/www/web30/html/piwik/core

However the error persists:

Fatal error: Class 'Piwik_Common' not found in /var/www/web30/html/piwik/core/Piwik.php on line 98

@robocoder commented on April 26th 2009 Contributor

My guess is that you have a /usr/share/php/Log.php file which Piwik finds instead of its own core/Log.php. Move /usr/share/php to the end of the include patch (as in Piwik's index.php).

@robocoder commented on April 26th 2009 Contributor

e.g., /var/www/web30/html/piwik:/var/www/web30/html/piwik/libs:/var/www/web30/html/piwik/plugins:/var/www/web30/html/piwik/core:/usr/share/php

@anonymous-piwik-user commented on April 26th 2009

Finally :) thx for the help

This Issue was closed on April 26th 2009
Powered by GitHub Issue Mirror