@duffybelfield opened this issue on August 7th 2014

Hi there,

I'm trying to use the standalone puppet modules to deploy piwik to a node.

Getting this error:

Error: Invalid parameter provider on Package[simplejson] at /etc/puppet/modules/piwik/manifests/loganalytics.pp:39

Any ideas?

@tsteur commented on August 7th 2014

Which version of vagrant are you using?

@duffybelfield commented on August 7th 2014

I'm trying to make this work with standalone puppet

@tsteur commented on August 7th 2014

I'm sorry we stopped supporting the Piwik Puppet standalone version 5 months ago see https://github.com/piwik/puppet-piwik .

Maybe it helps you to run puppet with some debug parameters like --debug --verbose --trace.

I used it about 3 or 4 weeks ago in combination with our vagrant box and it works fine. Puppet version is 2.7.19, not the latest > 3.*

This issue was closed on August 7th 2014
Powered by GitHub Issue Mirror