@tsteur opened this Issue on August 6th 2014 Owner

When publishing a plugin on the Marketplace we automatically run tests to make sure the plugin won't break Piwik and that it works with at least PHP 5.3. A new plugin was recently published that requires at least PHP 5.4 in the plugin.json as PHP 5.4 features are used. So after publishing the plugin the build discovered an issue when using PHP 5.3:

Parse error: syntax error, unexpected '[' in /home/travis/build/piwik/piwik-tests-plugins/piwik/plugins/LdapVisitorInfo/LdapVisitorInfo.php on line <i>45</i>

see https://travis-ci.org/piwik/piwik-tests-plugins/builds/31786476

As the developer has defined that at least PHP 5.4 is required we should run the tests on PHP 5.4 and not PHP 5.3

@mattab commented on August 6th 2014 Owner

Maybe it is not so easy to do as the PHP version is in the .travis.yml file which is pushed to the repository and we have no control over.

@tsteur commented on August 6th 2014 Owner

It is super easy as we generate the .travis.yml for each test using a twig template already anyway

@mattab commented on August 7th 2014 Owner

Looking good Thomas!

This Issue was closed on August 6th 2014
Powered by GitHub Issue Mirror