@milgner opened this Issue on July 30th 2014

On a fresh Piwik 2.4.1, when the <script> tag loads piwik.js from the installation URL, I receive errors in both Firefox and Chrome.

TypeError: G[S] is undefined (piwik.js:14:658)

Then, when navigating between pages another error occurs:

TypeError: _paq[r] is undefined (piwik.js:32:251)

But this may well be a follow-up error to the first one, of course.

Since the .js is minified, I realize that this is not that helpful, so please let me know if there's any more information I can contribute. The Piwik installation itself does not report any errors and "Settings -> System Check" shows green checkmarks throughout.

@mattab commented on August 3rd 2014 Owner

What tracking code do you use on your pages? Which browser? it works for us (and we have extensive tests testing it so hopefully should work for you too ;))

@milgner commented on August 4th 2014

I copied the tracking code from the Piwik admin interface and put it just before the closing </body> tag. It certainly looks correct and I have successfully set up Piwik on other projects in the past. The same error occurs in both Firefox and Chrome (both current versions).
I know that you're running extensive integration tests and am quite baffled as to what the reason for the error may be - but since i was at my wits end, I was hoping that someone might have stumbled upon the same problem.
Since that doesn't seem to be the case the only possible "solution" might be to completely remove and re-install Piwik :/

@mattab commented on August 4th 2014 Owner

@milgner if the error occurs in several browsers, could you send me the link URL where I could reproduce this error? we can investigate (and re-open this ticket!)

This Issue was closed on August 3rd 2014
Powered by GitHub Issue Mirror