@anonymous-piwik-user opened this Issue on February 26th 2009

I had a customer using IE6 today reporting javascript errors in our shop when he tries to check out.

I fired up Internet Explorer 6 and tried it myself and can reproduce the error. However, this is most likely due to Google Analytics (which currently runs side-by-side to Piwik). We have a ssl proxy for secure checkout and as the domain is different to the regular shop domain, links to the ssl area are wrapped into 'pageTracker._link()' in order not to loose the customer and miss the sale in the Google Analytics conversion.

The Microsoft Debugger claims an error in _pk_is_site_hostname(), the line in question is

if ( alias.substr(0, 2) == "*." ) {

At least it is the line highlighted by the debugger. I can't reproduce this in Firefox nor Safari, it only fails in Internet Explorer.

@robocoder commented on February 26th 2009 Contributor

Should be fixed in #566. Prototype and MooTools are culprits.

@mattab commented on February 27th 2009 Owner

msslovi0, can you please apply the patch in #566 and see if that fixes your bug?

vipsoft, I would also think this fixes the bug but because this one is critical (warning in browser) we have to make sure this is the case.

@robocoder commented on February 27th 2009 Contributor

Ok, I'll remember that when I'm triaging new tickets.

msslovi0: while we have your attention, can you also verify that your shop (eg ecombase) uses MooTools? Thanks.

@anonymous-piwik-user commented on February 27th 2009

The fix from #566 solves this one, too. Thanks for your fast response.

We're running a xt:Commerce-Shop (not Ecombase, which is forked from xt:C) and are not using Mootools. However, we are currently in a transition from Prototype/Scriptaculous to jQuery, so on some pages both frameworks are used (Prototype by default und jQuery in compatibility mode). If you need URLs, let me know.

This Issue was closed on August 14th 2009
Powered by GitHub Issue Mirror