@anonymous-piwik-user opened this issue on May 7th 2008

I saw this error, for the statistics of today, in a site with >5,000 visits/day:

+++++++++++++++++++++++++

Uncaught exception: 'Maximum recursion level of 20 reached. You have probably set a DataTable_Row with an associated DataTable which belongs already to its parent hierarchy.'

+++++++++++++++++++++++++

in every plugin that shows no graphic. (In those, the graphic appears empty and with light yellow background). And just a bit later, the statistic page for this site and for today became inaccessible, because it hangs both IE and Firefox (???). So now, there's no info for this site, but the rest of sites, or this site for other days, show their infos ok (if I don't take into account Ticket #203).

@anonymous-piwik-user commented on May 24th 2008

Attachment: error description as it appears in "List of Keywords" plugin error - List of Keywords.txt

@anonymous-piwik-user commented on May 24th 2008

Attachment: error description as it appears in "Overview with graph" plugin error - Overview with graph.txt

@anonymous-piwik-user commented on May 24th 2008

Attachment: error description as it appears in "Visitor browsers" plugin error - Visitor browsers.txt

@anonymous-piwik-user commented on May 24th 2008

Attachment: error description as it appears in "Visitor countries" plugin error - Visitor countries.txt

@anonymous-piwik-user commented on May 24th 2008

Attachment: web page as it appears for the day in which the error jumps. error - piwik web.png

@mattab commented on May 8th 2008

Hi rsg, because it is impossible for us to reproduce such a data-dependant bug, the only way to fix this would be if you can give me access to your piwik. If you think this is possible, please email your ftp/DB details to matt@piwik.org thanks

@anonymous-piwik-user commented on May 9th 2008

Hi matt, may be it's related to Ticket #203, which you've just patched. I've modified my DB following your instructions for piwik_archive_blob_XXXX_XX tables, so I'm gonna wait to see if statistics for next days are ok. I'll let you know the results. thanx

@mattab commented on May 29th 2008

rsg, the only thing I can think of is that some of your website URLs may have more than 20 slashes in them, am I right?

Do you have this error every day?

@anonymous-piwik-user commented on May 29th 2008

No, my urls have six slashes (http://www.site.org/path1/path2/path3/index.php?module=Home&action=in...).

The error appears just for ONE site with high traffic (I have other sites which have run for a month without errors), and just for a SPECIFIC DAY.

I had this error twice: in both cases, I deleted that site in piwik, I also manually deleted the site's data (delete from... where idsite=X), and upgraded piwik: in the first occasion I upgraded just the DB (#203), and in the second one I upgraded from v0.1.5 to v0.2.1 (I just decompressed piwik over the old one, DB is the same).

So the error seems data dependant. If it appears again, I'll let you know (It seems to appear after ten days of traffic or so...).

thanx

@anonymous-piwik-user commented on May 29th 2008

note: now the error DOESN'T hang the browser, as stated in the first description. (It was only related to patched #203).

@mattab commented on June 26th 2008

(In [525]) - improved echo output of DataTable (now showing user friendly output of datatable_Array) - refs #5628 hopefully fixed by limiting the number of levels in the Actions table hierarchy - refs #5544 started cleaning html code (patch by milianw)

@mattab commented on July 21st 2008

fixed publised in 0.2.6 Please reopen if you still experience the problem with new data.

This issue was closed on July 30th 2009
Powered by GitHub Issue Mirror