@mattab opened this issue on January 3rd 2008

Currently all APIs in Piwik and Plugins are not versionned. This means that if people start using the APIs and if the developpers decide to change some parameters in the method calls, the software would stop working.

This is annoying and not a good practise. We need to have a way to provide a backward compatibility APIs. There are simple ways to do it, like adding a new parameter "version" to every function call, or prefixing the API URL by the version number.

@mattab commented on October 14th 2008

we instead try to maintain backward compatibility from version 1.0 stable.

This issue was closed on October 14th 2008
Powered by GitHub Issue Mirror