@mattab opened this Issue on March 4th 2014 Owner

Class 'Piwik_Plugin' not found in /var/www/webs/stats/piwik/plugins/SecurityInfo/SecurityInfo.php 17 using PHP 5.4.25-pl0-gentoo

Happens every time when trying to uninstall incompatible plugins.

Reported by email.

Solution: Maybe we trigger this process in a new http request to prevent failure of main process?

Or maybe we define Piwik_Plugin as bridge to \Piwik\Plugin

@mattab commented on March 16th 2014 Owner

This particular bug was reported 27 times by email to the Piwik team from users.

@piotr-cz commented on January 8th 2015 Contributor

What is the recommended way to uninstall legacy plugins (which trigger such fatal error)?

@mattab commented on January 9th 2015 Owner

@piotr-cz delete the directory plugins/XYZ

@Croydon commented on July 29th 2016

Why is this closed when it's clearly not fixed?
Just throwing a fatal error is not really good UX.

This Issue was closed on March 28th 2014
Powered by GitHub Issue Mirror