@anonymous-piwik-user opened this Issue on February 19th 2014

When I include today in a date range my visitor and visits numbers jump drastically even though I haven't had many visitors today. I've got a number of sites running on my installation and this holds true across them all. I've included a date range without (1) and with today (2-19-14) (2), along with today only stats (3). You'll see they definitely don't add up properly.

[[Image(http://renmind.com/bugs/piwik-bug-report-1.png)]]

[[Image(http://renmind.com/bugs/piwik-bug-report-2.png)]]

[[Image(http://renmind.com/bugs/piwik-bug-report-3.png)]]
Keywords: date range, visitors, visits

@anonymous-piwik-user commented on February 19th 2014

So what I thought was a problem is not, but there is a problem. When I select a date range that ends in any date other than today the visitor numbers are coming up way short and the page actions aren't showing up in a reliable way.

[[Image(http://renmind.com/bugs/piwik-bug-report-4.png)]]

[[Image(http://renmind.com/bugs/piwik-bug-report-5.png)]]

[[Image(http://renmind.com/bugs/piwik-bug-report-6.png)]]

@mattab commented on February 21st 2014 Owner

I see you are using 2.0.3. Please upgrade to the latest RC version: http://forum.piwik.org/read.php?2,111814 as we have fixed a bug related to this.

If in the future (in a few weeks), when using 2.1 RC, for new future data, if you are still experiencing this issue, please comment again here.

@EreMaijala commented on March 6th 2014

I believe what we have encountered might stem from the same issue (but running 2.1), though I didn't have today included in the ranges. Here are the symptoms:

1.) The evolution graph for visits seems to display correct information, or at least the graph is similar for different ranges.

2.) Report for the month of Feb 2014 looks good, but report for 2014-02-01,2014-02-28 shows zeros for all values in the report.

3.) Report for 2014-02-01,2014-02-27 shows values way below what they should be according to the evolution graph. Similarly report for 2014-01-01,2014-01-30 shows very low values.

4.) Report for 2014-02-01,2014-03-01 looks correct.

5.) API call for e.g. VisitsSummary.getVisits shows similarly wrong values as the reports above.

The issues were found while running 2.02, but upgrading to 2.1 didn't solve them. We have disabled archiving triggered by browser requests and run archiving via cron hourly. I also tried to delete piwikarchive* tables and run archiving anew (with --force-all-websites and --force-all-periods=1) to no avail.

I finally found that Piwik will report correct values if I enable always_archive_data_range in [Debug] section, but I understand it shouldn't need to be enabled. Additionally, it seems it will always add rows to archive tables (e.g. piwik_archive_numeric_2014_02), so it ends up containing a lot of duplicates.

@tsteur commented on April 10th 2014 Owner

Hi,

I just wanted to work on this but couldn't reproduce it. Can you still reproduce this issue? Using the latest Piwik? If yes, do you think you could provide us a login for your Piwik instance and maybe even for your ftp to debug this issue? I'd really like to fix this issue. If so, send us an email to hello@piwik.org

BTW: I think the actual problem is that it displays too less visits when today is not included and the correct data when today is included. Having a look on the "Evolution over period" screen there are on average about 200 visitors over 50days. So the expected number is about 10k and 7k visitors when not included today seems to be too less

@EreMaijala commented on April 10th 2014

Unfortunately I'm unable to reproduce this anymore. Nothing has changed apart from us having always_archive_data_range enabled for a while. Now I disabled it to test this again and all queries seem ok.

@tsteur commented on April 10th 2014 Owner

Perfect! Will close it for now but feel free to reopen anytime in case you experience this issue again.

This Issue was closed on April 10th 2014
Powered by GitHub Issue Mirror