@anonymous-piwik-user opened this Issue on January 5th 2014

Hi there,

I upgraded from 1.12 to 2.0.2. During the upgrade on the commandline, I got the following terminal output:

# /opt/php54/bin/php index.php -- "module=CoreUpdater"

<div style='word-wrap: break-word; border: 3px solid red; padding:4px; width:70%; background-color:#FFFF96;'>
        <strong>There is an error. Please report the message (Piwik 2.0.2)
        and full backtrace in the <a href='?module=Proxy&action=redirect&url=http://forum.piwik.org' target='_blank'>Piwik forums</a> (please do a Search first as it might have been reported already!).<br /><br/>
        Notice:</strong> <em>Undefined offset: 2</em> in <strong>piwik/core/SettingsPiwik.php</strong> on line <strong>310</strong>
<br /><br />Backtrace --&gt;<div style="font-family:Courier;font-size:10pt"><br />
<a href='/0'>#0</a>  Piwik\Error::errorHandler(...) called at [piwik/core/SettingsPiwik.php:310]<br />
<a href='/1'>#1</a>  Piwik\SettingsPiwik::getCurrentGitBranch(...) called at [piwik/core/Filechecks.php:124]<br />
<a href='/2'>#2</a>  Piwik\Filechecks::getFileIntegrityInformation(...) called at [piwik/plugins/CoreUpdater/Controller.php:353]<br />
<a href='/3'>#3</a>  Piwik\Plugins\CoreUpdater\Controller->doWelcomeUpdates(...) called at [piwik/plugins/CoreUpdater/Controller.php:295]<br />
<a href='/4'>#4</a>  Piwik\Plugins\CoreUpdater\Controller->runUpdaterAndExit(...) called at [piwik/plugins/CoreUpdater/Controller.php:275]<br />
<a href='/5'>#5</a>  Piwik\Plugins\CoreUpdater\Controller->index(...) called at [:]<br />
<a href='/6'>#6</a>  call_user_func_array(...) called at [piwik/core/FrontController.php:117]<br />
<a href='/7'>#7</a>  Piwik\FrontController->dispatch(...) called at [piwik/index.php:71]<br />
</div><br />
 </pre></div><br />

*** Update ***

    Database Upgrade Required

    Your Piwik database is out-of-date, and must be upgraded before you can continue.

            Piwik database will be upgraded from version 1.12 to the new version 2.0.2.

            The following plugins will be updated: DevicesDetection.

    The database upgrade process may take a while, so please be patient.

During that time, visiting the index page in a browser would yield the same message:

There is an error. Please report the message (Piwik 2.0.2) and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Notice: Undefined offset: 2 in piwik/core/SettingsPiwik.php on line 310

Backtrace -->

<a href='/0'>#0</a> Piwik\Error::errorHandler(...) called at [piwik/core/SettingsPiwik.php:310]
<a href='/1'>#1</a> Piwik\SettingsPiwik::getCurrentGitBranch(...) called at [piwik/core/Filechecks.php:124]
<a href='/2'>#2</a> Piwik\Filechecks::getFileIntegrityInformation(...) called at [piwik/plugins/CoreUpdater/Controller.php:353]
<a href='/3'>#3</a> Piwik\Plugins\CoreUpdater\Controller->doWelcomeUpdates(...) called at [piwik/plugins/CoreUpdater/Controller.php:316]
<a href='/4'>#4</a> Piwik\Plugins\CoreUpdater\Controller->runUpdaterAndExit(...) called at [piwik/plugins/CoreUpdater/Controller.php:275]
<a href='/5'>#5</a> Piwik\Plugins\CoreUpdater\Controller->index(...) called at [:]
<a href='/6'>#6</a> call_user_func_array(...) called at [piwik/core/FrontController.php:117]
<a href='/7'>#7</a> Piwik\FrontController->dispatch(...) called at [piwik/index.php:71]

However, as you can guess from the terminal output, it seems like the update did complete successfully. My Piwik 2.0.2 instance seems to be functioning normally.

The bug persists however. If I visit /index.php?module=Installation&action=systemCheckPage from the admin menu, I get the same traceback:

Notice: Undefined offset: 2 in piwik/core/SettingsPiwik.php on line 310

Backtrace -->

<a href='/0'>#0</a> Piwik\Error::errorHandler(...) called at [piwik/core/SettingsPiwik.php:310]
<a href='/1'>#1</a> Piwik\SettingsPiwik::getCurrentGitBranch(...) called at [piwik/core/Filechecks.php:124]
<a href='/2'>#2</a> Piwik\Filechecks::getFileIntegrityInformation(...) called at [piwik/plugins/Installation/Controller.php:857]
<a href='/3'>#3</a> Piwik\Plugins\Installation\Controller::getSystemInformation(...) called at [piwik/plugins/Installation/Controller.php:950]
<a href='/4'>#4</a> Piwik\Plugins\Installation\Controller->setupSystemCheckView(...) called at [piwik/plugins/Installation/Controller.php:520]
<a href='/5'>#5</a> Piwik\Plugins\Installation\Controller->systemCheckPage(...) called at [:]
<a href='/6'>#6</a> call_user_func_array(...) called at [piwik/core/FrontController.php:117]
<a href='/7'>#7</a> Piwik\FrontController->dispatch(...) called at [piwik/index.php:71]
@mattab commented on January 5th 2014 Owner

Thanks for the report, already fixed in git

This Issue was closed on January 5th 2014
Powered by GitHub Issue Mirror