@DaSchTour opened this Issue on December 17th 2013 Contributor

After updating to 2.0 there are PHP Errors everywhere
They all miss the Piwik/Log class
Fatal error: Class 'Piwik\Log' not found in /.../httpdocs/core/DataTable/Filter.php on line 57 Fatal error: Class 'Piwik\DataTable\Twig_Template' not found in /.../httpdocs/tmp/templates_c/35/b2/68c33fe2eb274cd1cfee977b5b621dbbd401984a71e15e72e2efcaed9ca3.php on line 5
This is a total mess
And I hoped that 2.0 would be a great update but this is a total disaster!

@DaSchTour commented on December 17th 2013 Contributor

Great Idea to distribute an update that raises PHP requirement to PHP 5.3.4 (I have 5.3.3 on Ubuntu 12.04 LTS) without telling anybody! This way you'll never kill Google Analytics. I now have to upgrade my complete Server just to use your fucking Piwik 2.0!

@anonymous-piwik-user commented on December 17th 2013

I confirm this issue.

On a fresh install on 10.04, Piwik doesn't complain about php version. However, it simply doesn't work due to the piwik/log error.
I need to upgrade to php5.3.6 to solve the problem.

@anonymous-piwik-user commented on December 18th 2013

Replying to DaSch:

Great Idea to distribute an update that raises PHP requirement to PHP 5.3.4 (I have 5.3.3 on Ubuntu 12.04 LTS) without telling anybody! This way you'll never kill Google Analytics. I now have to upgrade my complete Server just to use your fucking Piwik 2.0!

While your issue is absolutely legitimate, the venom and language of your response is not warranted.

To be blunt, you don't have to use PIwik 2.0. There's nothing wrong with 1.x.

@anonymous-piwik-user commented on December 18th 2013

Replying to LyndsySimon:

Replying to DaSch:

Great Idea to distribute an update that raises PHP requirement to PHP 5.3.4 (I have 5.3.3 on Ubuntu 12.04 LTS) without telling anybody! This way you'll never kill Google Analytics. I now have to upgrade my complete Server just to use your fucking Piwik 2.0!

While your issue is absolutely legitimate, the venom and language of your response is not warranted.

To be blunt, you don't have to use PIwik 2.0. There's nothing wrong with 1.x.

Maybe we can help you to identify what in the piwik's code need at least 5.3.4 ? Or it's by design so everybody absolutely need to upgrade the php version ?

@DaSchTour commented on December 20th 2013 Contributor

is duplicate of #4398

@anonymous-piwik-user commented on December 20th 2013

Replying to ludopaquet:

Replying to LyndsySimon:

Replying to DaSch:

Great Idea to distribute an update that raises PHP requirement to PHP 5.3.4 (I have 5.3.3 on Ubuntu 12.04 LTS) without telling anybody! This way you'll never kill Google Analytics. I now have to upgrade my complete Server just to use your fucking Piwik 2.0!

While your issue is absolutely legitimate, the venom and language of your response is not warranted.

To be blunt, you don't have to use PIwik 2.0. There's nothing wrong with 1.x.

Maybe we can help you to identify what in the piwik's code need at least 5.3.4 ? Or it's by design so everybody absolutely need to upgrade the php version ?

To be clear, I'm just a user.

I was a bit miffed to read the comment above, is all. I'd been working on integrated Piwik into a complex setup for a several hours, and came here to document a few specific but relatively minor issues with 2.0, which I had already confirmed with other users via IRC. I honestly shouldn't have been so blunt, but I take F/OSS development pretty seriously, and it gets under my skin a bit when people seemingly verbally abuse developers. It's a fulfilling job, but it isn't easy, and you have to remember that most of people are doing it for free, because they are personally motivated to work on a project. Nothing kills motivation quite so fast as someone lambasting you for a product you worked hard on and gave away for free.

It's also not terribly much to ask that users upgrade their PHP interpreter once every three years or so...

@DaSchTour commented on December 21st 2013 Contributor

It seams your are not to deep into Linux. I have a V-Server with Ubuntu 10.04 LTS and Plesk with a lot of pages on there. And there it's not that easy to upgrade PHP and it's also a lot of work to migrate to a new server. And the Setup of Ubuntu 10.04 with PHP 5.3.3 is widely used. And I work with a lot of PHP Software but I've never seen a situation where a commonly used configuration didn't work. So in my eyes there is a big issue in testing with Piwik.
I'm sorry that I overreacted a bit, but from my point of view that's a beginners error.
I'm also a bit into developer and mainly software-tester. And testing is the most important thing about software. And such common configuration have to be tested before releasing new software ;)

@mattab commented on December 25th 2013 Owner

Duplicates #4427 (which should be fixed by https://github.com/piwik/piwik/commit/58ee8846720a23044695671564291ce31327eab2 )

If not working please reopen with exact messages

This Issue was closed on December 26th 2013
Powered by GitHub Issue Mirror