@BeezyT opened this Issue on June 17th 2013 Member

The Segmen Editor/Selector doesn't work in IE8.

In fact, it throws an error and causes JS to crash, so Piwik is not usable anymore when the Segment Editor is enabled.

This ticket contains fixes and is a place for discussion whether we want to support IE8 at all.

@BeezyT commented on June 17th 2013 Member

In 84fb1bf34ae5f2fb8b1bc28f6219aeb5788518aa (which i committed by accident with the wrong message), the main problems are fixed. JS does not crash anymore and Piwik can be used.

@BeezyT commented on June 17th 2013 Member

In c27a972a156534b05c43df657a96a59afce2a699: refs #4012 fixing two more for-in loops for ie8

@BeezyT commented on June 17th 2013 Member

The Segment Selector works now.

Editing Segments seems like it would be a lot of work to adapt to IE8.

@mattab commented on June 18th 2013 Owner

Very nice that at least the selector works!

@mattab commented on September 16th 2013 Owner

Moving 1.x closed tickets to 2.0

This Issue was closed on September 16th 2013
Powered by GitHub Issue Mirror