@anonymous-piwik-user opened this Issue on March 4th 2013

Configuring Piwik in Log import mode, I found many visits coming from a Netscape browser, but "Netscape" never occurs in my logs.
So I wrote a little logger into UserAgentParser.php, to find out what was identified as Natscape, here's the result:

Mozilla/5.0 (compatible; Ezooms/1.0; ezooms.bot<a class='mention' href='https://github.com/gmail'>@gmail</a>.com)
Mozilla/5.0 (compatible; Blekkobot; ScoutJet; +http://blekko.com/about/blekkobot)
Mozilla/3.0 (compatible; Indy Library)
Mozilla/5.0 (compatible; Genieo/1.0 http://www.genieo.com/webfilter.html)

These lines are repeated several times, even if i do not set the --enable_bots option.
I reported only unique values.

I'm opening this ticket as suggested by Matt in the community forum, I hope this report will help to solve this issue.
Thanks!

@anonymous-piwik-user commented on February 17th 2014

Attachment: image browser table
piwik browser view.png

@mattab commented on March 11th 2013 Owner

Thx for the report.

=> I think we should be a bit more clever here, and mark these so-called "Netscape" as "Bots"

@anonymous-piwik-user commented on February 17th 2014

Hi ,

I get this view of the browsers used. [[Image(http://issues.piwik.org/attachments/3788/piwik%20browser%20view.png)]]

I am using the standard dashboard, in piwik 2.03, and the yireo plugin to a joomla website.

Seems somewhat weird.

Greetings,
Paul

@sgiehl commented on February 17th 2014 Member

The old useragentparser might detected those useragents as netscape.
Using the DevicesDetection plugin should fix that issue. The new UserAgentParerEnhanced should detect those as Bots with an Unknown browser.

@Paul: The DevicesDetection plugin isn't active by default in Piwik 2.0. Please try to activate it.

@anonymous-piwik-user commented on February 17th 2014

Okay. Thanks.
After activating the DevicesDetection plugin it reports these as unknown. Is it possible to parse the older data using this newly installed plugin?

@sgiehl commented on February 17th 2014 Member

Sorry, that is not possible. We do not store the useragent in the database, thus it's not possible to reparse it.

This Issue was closed on February 25th 2014
Powered by GitHub Issue Mirror