@anonymous-piwik-user opened this issue on February 2nd 2013

I've upgraded from 1.8.3 to 1.10.1. The iframe-based opt-out mechanism, which used to work flawlessly for me, stopped working. Checking or unchecking the tickbox shown in the iframe causes the tickbox to immediately revert to its prior state (so neither can you opt-in nor can you opt-out).

To be precise, I have several sites running on the same server, in different domains. Piwik admin and UI is on its own domain (but all on the same server and file system). All sites point their own location, via Apache config file Alias directive, to Piwik's physical directory (Alias /piwik /var/xxxx/piwik), so:

site1.com/piwik -> /var/xxxx/piwik site2.com/piwik -> /var/xxxx/piwik, and so on.

The iframe is called from within each own site: src="http://site1.com/piwik/index.php?module=CoreAdminHome&action=optOut&language=en"

As far as I can see, Piwik is no longer able to manipulate the opt-out cookie, i.e. no cookie is being added or removed, for each site. However, it is able to manipulate the cookie, and the opt-out, for its own admin/UI sitehowever, that one is kept private.

I wonder what has changed since 1.8.3 with regards how the opt-out cookie is being generated and stored and could that change be the reason the opt-out is no longer working.

@halfdan commented on February 2nd 2013

I believe this is a duplicate of #3568. Can you check if the solution provided there works for you?

@anonymous-piwik-user commented on February 2nd 2013

Indeed, the solution to #3568 resolves my issue. Thank you, halfdan, for pointing me to this, very much!

This issue was closed on February 2nd 2013
Powered by GitHub Issue Mirror