@anonymous-piwik-user opened this Issue on December 14th 2012

Having configured a custom Page Title delimiter (say "::") everything involving Page URLs still works nice, on the other hand instead every Transitions report involving Page Titles gives a "no data error"

The message returned clicking on the transitions icon, is something like the following:

There's no data for Site Name/Page Title Example

Either the action had no pageviews during the period
or it is invalid.

Of course the right page title for the above example is "Site Name::Page Title Example"

Keywords: transitions

@anonymous-piwik-user commented on December 17th 2012

Uh ? ... Why "low"? this bug makes Transitions completely unusable for anybody having defined a custom delimiter ... ;(

@mattab commented on March 16th 2014 Owner

See also #4595

@mattab commented on April 27th 2014 Owner

Moving bugs to our current milestone to make the backlog more realistic.

@dcharro commented on May 29th 2015

Same problem yet in 2.13.1
I'm not an expert but I'm trying to explore the code and look for a solution.

core/Config.php needs to provide action_title_category_delimiter. So, I add a similar line like that for url_category_delimiter

'action_url_category_delimiter' => $general['action_url_category_delimiter'],
'action_title_category_delimiter' => $general['action_title_category_delimiter'],

In my opinion, next step will be changing plugins/Transitions/javascripts/transitions.js and use action_title_category_delimiter when the user is in Page Title. I don't know how to do this correctly without side effects.

I hope this help you fix this bug.

Thank you.

Powered by GitHub Issue Mirror