@mattab opened this Issue on June 3rd 2012 Owner

Reported in forum

Notice: Undefined offset: 0 in /home/matrix/domains/piwik.matr**.*/public_html/core/DataTable.php on line 470 

Backtrace -->
<a href='/0'>#0</a> Piwik_ErrorHandler(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/DataTable.php:470]<a href='/1'>#1</a> Piwik_DataTable->getRowFromLabel(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/DataTable.php:513]<a href='/2'>#2</a> Piwik_DataTable->getFilteredTableFromLabel(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/DataTable/Array.php:252]<a href='/3'>#3</a> Piwik_DataTable_Array->getFilteredTableFromLabel(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/API/DataTableManipulator/LabelFilter.php:72]<a href='/4'>#4</a> Piwik_API_DataTableManipulator_LabelFilter->filter(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/API/ResponseBuilder.php:323]<a href='/5'>#5</a> Piwik_API_ResponseBuilder->handleDataTable(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/API/ResponseBuilder.php:79]<a href='/6'>#6</a> Piwik_API_ResponseBuilder->getResponse(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/API/Request.php:130]<a href='/7'>#7</a> Piwik_API_Request->process(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/plugins/API/API.php:1195]<a href='/8'>#8</a> Piwik_API_API->loadRowEvolutionDataFromAPI(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/plugins/API/API.php:1092]<a href='/9'>#9</a> Piwik_API_API->getSingleRowEvolution(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/plugins/API/API.php:1078]<a href='/10'>#10</a> Piwik_API_API->getRowEvolution(...) called at [:]<a href='/11'>#11</a> call_user_func_array(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/API/Proxy.php:190]<a href='/12'>#12</a> Piwik_API_Proxy->call(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/API/Request.php:128]<a href='/13'>#13</a> Piwik_API_Request->process(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/plugins/CoreHome/DataTableRowAction/RowEvolution.php:162]<a href='/14'>#14</a> Piwik_CoreHome_DataTableRowAction_RowEvolution->loadEvolutionReport(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/plugins/CoreHome/DataTableRowAction/RowEvolution.php:99]<a href='/15'>#15</a> Piwik_CoreHome_DataTableRowAction_RowEvolution->__construct(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/plugins/CoreHome/Controller.php:138]<a href='/16'>#16</a> Piwik_CoreHome_Controller->getRowEvolutionPopover(...) called at [:]<a href='/17'>#17</a> call_user_func_array(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/FrontController.php:138]<a href='/18'>#18</a> Piwik_FrontController->dispatch(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/index.php:53]
@mattab commented on July 25th 2012 Owner

(In [6548]) Refs #3180 Maybe fixes the issue but maybe we should look for the original problem?

@mattab commented on July 31st 2012 Owner

(In [6599]) Fixes #3180 Found the bug!

This Issue was closed on July 31st 2012
Powered by GitHub Issue Mirror