@anonymous-piwik-user opened this Issue on October 31st 2011

In piwik_log_action.name Russian characters are stored with the issues (question marks "??????"). Although, for example, in table piwik_log_action.referer_keyword stored without error...

Judging by the logs errors began in September (occasionally update from SVN)

@robocoder commented on October 31st 2011 Contributor

We do not support direct access to the Piwik database. You must use Piwik's API.

In the case of referer_keyword, Piwik programmatically decodes the referer.

@robocoder commented on October 31st 2011 Contributor

p.s. updating from svn is at your own risk. Make sure you may have this changeset: [5324]

@anonymous-piwik-user commented on October 31st 2011

Excuse me, if not described the problem. I'll try again. The error occurs in the derivation of page titles (or rather, at what stage is saved in the database until you can find a method that would show)
[http://stat.z-gu.ru/?module=API&method=Actions.getPageTitles&idSite=6&date=yesterday&period=day&format=html&filter_limit=10]

In backend looks so: [http://hostingkartinok.com/image/01201110/4274cf70cb2b2299d19b1b106ef758a6.png]

Although the module keywords - works fine:
[http://stat.z-gu.ru/?module=API&method=Referers.getKeywords&idSite=6&date=yesterday&period=day&format=html&filter_limit=10]

At least direct where to look. Thanks in advance.

p.s.: I'm using version 5398

@anonymous-piwik-user commented on November 3rd 2011

hm... problem solved

possibly after removal all

default-character-set=*

(was default-character-set=utf8)

from /etc/mysql/my.cnf

and reboot server

This Issue was closed on November 3rd 2011
Powered by GitHub Issue Mirror