@anonymous-piwik-user opened this Issue on June 16th 2011

hi,

the tracking-code from the SiteManager-Site looks like this:
http://your-url.../piwik.php?idsite=1

the Image-Only-Tag ends on:
....piwik.php?idsite=1&rec=1

It looks like that images with no &rec=1 were ignored maybe the default-js-code has to be fixed?

@robocoder commented on June 17th 2011 Contributor

No, this is intentionally the default in order to not track bots. If you add rec=1, I suggest you try the third party plugin, BotTracker.

@anonymous-piwik-user commented on June 17th 2011

Replying to vipsoft:

No, this is intentionally the default in order to not track bots. If you add rec=1, I suggest you try the third party plugin, BotTracker.

i got both codes from the piwik-page: .../index.php?module=SitesManager&action=displayJavascriptCode

<noscript><p><img src="http://.../piwik.php?idsite=1" style="border:0" alt="" /></p></noscript>

and with no js:
<img src="https://.../piwik.php?idsite=1&rec=1" style="border:0" alt="" />

the noscript-tag doesn't count for me with a non-JS-Browser :-(

rec - (required) The parameter &rec=1 is required to force the request to be recorded

@mattab commented on June 17th 2011 Owner
@anonymous-piwik-user commented on June 17th 2011

Replying to matt:

but why is there a noscript-tag at all when it doesn't work ;)

[http://tinyurl.com/679uf8j]

schorsch

@anonymous-piwik-user commented on June 17th 2011

that's cool :) a link to forum . piwik . org doesn't pass akismet :)

@robocoder commented on June 17th 2011 Contributor

in the future, we'll either include BotTracker (or similar), or allow plugins to override the javascript tag template, or provide an option in the (planned) tag builder.

@anonymous-piwik-user commented on June 17th 2011

thanx a lot ;) would be nice

This Issue was closed on June 17th 2011
Powered by GitHub Issue Mirror