@anonymous-piwik-user opened this issue on March 20th 2010

Most of the core plugins are using Piwik_Version::VERSION for their version number, but not so for the example plugins.

The version number policy is: - core plugins (distributed in the Piwik release, with the exception of examples) use Piwik_Version::VERSION, so that they always reflect/match the base version - example plugins use a hard-coded version number as an example for 3rd party developers (e.g., '0.1') - 3rd party plugins use a hard-coded version number that must be incremented with each plugin release

A policy for transitioning 3rd party plugins to core will be formalized after #1116.

@anonymous-piwik-user commented on March 20th 2010

Attachment: plugin-numbers.patch

@robocoder commented on March 20th 2010

(In [1964]) fixes #1222 - document the version number policy; point developers (who read the code) to Piwik_Plugin (core/Plugin.php)

This issue was closed on March 20th 2010
Powered by GitHub Issue Mirror