@alfonso-romero opened this Issue on July 26th 2017

Hi

I'm currently starting to use the events feature, and right now I'm able to track and store some test data including event categories, event actions and event names.

The problem is on the report, when I go to Dashboard -> Actions -> Events, all 3 tabs show that "there is no data for this report". I checked the database and I can see the data correctly stored on log_link_visit_action and log_action tables with my events, but reports just won't display anything, even when I can see visitor logs correctly, the issue is only with events reports.

Of course I made sure to pick the correct site and date for the events activity I'm tracking, but reports are just not showing up.

Am I missing some setting to enable this reports somewhere else? or is there any other method or data I should implement/track to be able to see the reports?

Thanks in advance

@GitFr33 commented on September 2nd 2017

Are you using a segment?

I have encountered a similar difficulty ( https://forum.piwik.org/t/piwik-events-showing-in-visitor-log-but-not-in-events-view/25409/2 ) and discovered that it only occurs when a segment other then ALL VISITS is used.

@GitFr33 commented on September 4th 2017

Can anyone else reproduce this issue?

  1. Piwik installation that does not use cron
  2. Piwik version 3.0.4
  3. Event tracked using _paq.push(['trackEvent', 'category', 'action', 'value']);
  4. URL based segment

I tried to reproduce this issue on the Piwik demo and it did not occur but I was was not able to confirm conditions 1-3

@mattab commented on September 18th 2017 Owner

@GitFr33 do you still experience this issue?

@GitFr33 commented on September 18th 2017

@mattab Yes. (using v 3.1.0)

@hpvd commented on September 18th 2017

in our installation everything is working fine (3.1.1b2)
there are events shown in events widgets and also in events reports.
example:
2017-09-18_21h32_25

@GitFr33 commented on September 18th 2017

@hpvd in the screenshot it doesn't look like you are using a segment. What happens when you select something other then All Visits in the segment dropdown?

@hpvd commented on September 18th 2017

it's also working as expected. e.g. segment: device is desktop (please see attachment)

2017-09-18_22h00_36

@GitFr33 commented on September 19th 2017

Interesting! How did you get version 3.1.1b2?
My instillation says it's up to date, but the version number is 3.1.0.

@Findus23 commented on September 19th 2017 Member

@GitFr33
As it is a beta release you’ll need to enable them in the settings first.

@GitFr33 commented on September 19th 2017

I see. Probably not a good idea for a production instillation?

@GitFr33 commented on September 19th 2017

Thanks for your continued assistance
I updated to 3.1.1b2 and the problem persisted.

More experimentation has revealed that this issue only occurs when a page URL or action URL based segment is used. In a certain way this makes sense because the events themselves don't have any URL.

Is this a bug or a feature? It certainly has had me puzzled...

@hpvd commented on September 20th 2017

Just checked your named details in our installation.
Your are right!
2017-09-20_07h15_16

@mattab : I could reproduce this problem also in 3.1.1b3 - seems to be a bug.

@hpvd commented on September 20th 2017

problem seems to occur in event reports and event widgets.

@mattab commented on September 20th 2017 Owner

Maybe it's similar to the issue here: https://github.com/piwik/piwik/issues/11992
which describes the "Downloads" report as not showing data for Segments Page URL contains.
Could you please try if Downloads show data? if so, we'd mark the issue as duplicate and consolidate both issues into one.

@hpvd commented on September 20th 2017

Just tested:
if segment is url the following reports are empty:

  • events
  • download
  • sitesearch
  • outlinks

=> so it's a general and with this a major problem.
Should one open a new issue for it?

btw: one can easily test this if one put "page url" -contains- domain of the page.

@mattab commented on September 22nd 2017 Owner

Thanks @hpvd for confirming.

Should one open a new issue for it?

No this issue is fine, just renamed it to broaden scope

@mattab commented on September 22nd 2017 Owner

This seems related: Inform users why there is no data in some actions report when action/event segment is applied #9796

@hpvd commented on September 23rd 2017

Is this maybe somehow related to https://github.com/piwik/piwik/issues/11806 ?

@mattab commented on September 24th 2017 Owner

@hpvd It does not look like they are related

@ChristianLuxem commented on November 22nd 2017

@mattab any idea in which milestone this could be fixed? I don't see it planned for a milestone yet...
Or is there a workaround that i could use?

@obliqueshock commented on December 5th 2017

The same issue shows up even using the 'Page Name' segment. Any smart workarounds to filter on specific pages?

Powered by GitHub Issue Mirror