@diosmosis opened this Pull Request on July 11th 2017 Member

This PR can be reviewed commit by commit.

Not sure if this can be merged, I wanted to use .component() which isn't available in 1.4.

Changes:

  • Updated angular & related packages to version 1.6.
  • Updated ngDialog to latest version.

Notes:

Angular 1.6 should be compatible w/ IE9+, but I haven't tested manually yet. If there's anything that should be tested manually on certain browsers, let me know.

@mattab commented on July 11th 2017 Owner

UI tests are passing which is promising. @sgiehl maybe you have some feedback as well. we could merge this as soon as 3.0.5 is released and then cut a beta to check whether all plugins builds will pass?

@sgiehl commented on July 11th 2017 Member

@mattab Will have a closer look the next days, but let's merge after 3.0.5 as you suggested.

@diosmosis commented on July 11th 2017 Member

Did a quick check on a VM w/ IE9, seems broken on 3.x-dev, not sure why. (Also broken on demo.piwik.org).

Some pages don't load (like the dashboard), some look odd, like the visitors log. Known issues?

@diosmosis commented on July 17th 2017 Member

Noticed the screenshots aren't stored in LFS, need to fix that before this can be merged.

Nevermind, github LFS notification isn't everywhere.

@tsteur commented on July 17th 2017 Owner

FYI: We dropped IE9 support with Piwik 3

@diosmosis commented on July 17th 2017 Member

That's good, I'll check on ie10 :)

@diosmosis commented on July 18th 2017 Member

Looks like it's working on ie10. Did a cursory check of dialogs via row actions + a couple pages + the top controls.

@mattab commented on July 24th 2017 Owner

Good to hear @diosmosis - we'll merge this in the coming days and cut a beta then

@mattab commented on September 11th 2017 Owner

We just released 3.1.0 so now merging this PR so we have time to test in the beta cycle

This Pull Request was closed on September 11th 2017
Powered by GitHub Issue Mirror