Must it be the same as the class name? Is it used anywhere?
let's clarify this and/or remove it if not useful (if we display the class name only, we don't need a human readable plugin name)
getName() isn't the same as the class name, e.g., 'CoreHome' vs 'Piwik_CoreHome'
getName() is used in two places: - in core/PluginsManager.php where it is used in the exception message if installPlugin() fails - in core/View.php where it is assigned to currentPluginName and displayed (human readable) next to the Piwik logo (in plugins/CoreHome/templates/logo.tpl)
This is not used by CorePluginsAdmin where it displays the name of each plugin. Here it uses readPluginsDirectory().
Given the above, we could enforce this consistency by adding a check to CorePluginsAdmin/Controller.php's index() -- skip any plugins where these don't match up.
Oh, I see what you mean. Yes, it would seem that getName() and getClassName() duplicate each other.
Ok. Revised suggestion: - document that getName() is the human readable plugin name (may contain spaces, punctuation; similarity to the plugin name is encouraged; translateable?) - in CorePluginsAdmin/Controller.php -- use getName() instead of the plugin's directory name when displaying the list of plugins - add a check to ensure all the human readable plugin names are unique, and that getClassName() matches the plugin's directory name; should be sufficient to check this constraint at installation, updates, and when installing new plugins
actually, why do we need getClassName() if it must return the directory name? maybe we can get rid of it and parse it from the dir name.
In http://dev.piwik.org/trac/wiki/Plugins/HowToWritePlugin?action=diff&version=15 - refs #1152, remove reference to "name" in getInformation() array
(In ) refs #1152 -deprecate "name" in getInformation() array;use getClassName() instead of getName(); remove unused getName()
(In ) fixes #1152 - remove deprecated "name" from getInformation() array
(In ) refs #1152 - add "final" keyword to getClassName() because we dont want subclasses (plugins) to redefine this; remove "name" from phpdocs