@abolfazl-ziaratban opened this Issue on February 16th 2017

i install piwik and after login , i get this errors :

WARNING: .../plugins/RssWidget/RssRenderer.php(47): Warning - simplexml_load_string(): ^ - Piwik 3.0.1 - Please report this message in the Piwik forums: http://forum.piwik.org (please do a search first as it might have been reported already)
WARNING: .../plugins/RssWidget/RssRenderer.php(47): Warning - simplexml_load_string(): " marginheight="0" frameborder="0" vspace="0" hspace="0"></iframe></body></html> - Piwik 3.0.1 - Please report this message in the Piwik forums: http://forum.piwik.org (please do a search first as it might have been reported already)
WARNING: .../plugins/RssWidget/RssRenderer.php(47): Warning - simplexml_load_string(): Entity: line 2: parser error : Premature end of data in tag html line 1 - Piwik 3.0.1 - Please report this message in the Piwik forums: http://forum.piwik.org (please do a search first as it might have been reported already)
WARNING: .../plugins/RssWidget/RssRenderer.php(47): Warning - simplexml_load_string(): " marginheight="0" frameborder="0" vspace="0" hspace="0"></iframe></body></html> - Piwik 3.0.1 - Please report this message in the Piwik forums: http://forum.piwik.org (please do a search first as it might have been reported already)
WARNING: .../plugins/RssWidget/RssRenderer.php(47): Warning - simplexml_load_string(): ^ - Piwik 3.0.1 - Please report this message in the Piwik forums: http://forum.piwik.org (please do a search first as it might have been reported already)
WARNING: .../plugins/RssWidget/RssRenderer.php(47): Warning - simplexml_load_string(): Entity: line 2: parser error : Opening and ending tag mismatch: head line 1 and html - Piwik 3.0.1 - Please report this message in the Piwik forums: http://forum.piwik.org (please do a search first as it might have been reported already)
WARNING: .../plugins/RssWidget/RssRenderer.php(47): Warning - simplexml_load_string(): ^ - Piwik 3.0.1 - Please report this message in the Piwik forums: http://forum.piwik.org (please do a search first as it might have been reported already)
WARNING: .../plugins/RssWidget/RssRenderer.php(47): Warning - simplexml_load_string(): </title></head><body><iframe src="http://10.10.34.34?type=Invalid Site&policy=Ma - Piwik 3.0.1 - Please report this message in the Piwik forums: http://forum.piwik.org (please do a search first as it might have been reported already)
WARNING: .../plugins/RssWidget/RssRenderer.php(47): Warning - simplexml_load_string(): ^ - Piwik 3.0.1 - Please report this message in the Piwik forums: http://forum.piwik.org (please do a search first as it might have been reported already)
WARNING: .../plugins/RssWidget/RssRenderer.php(47): Warning - simplexml_load_string(): Entity: line 2: parser error : EntityRef: expecting ';' - Piwik 3.0.1 - Please report this message in the Piwik forums: http://forum.piwik.org (please do a search first as it might have been reported already)
WARNING: .../plugins/RssWidget/RssRenderer.php(47): Warning - simplexml_load_string(): </title></head><body><iframe src="http://10.10.34.34?type=Invalid Site&policy=Ma - Piwik 3.0.1 - Please report this message in the Piwik forums: http://forum.piwik.org (please do a search first as it might have been reported already)
WARNING: .../plugins/RssWidget/RssRenderer.php(47): Warning - simplexml_load_string(): Entity: line 2: parser error : Opening and ending tag mismatch: meta line 1 and head - Piwik 3.0.1 - Please report this message in the Piwik forums: http://forum.piwik.org (please do a search first as it might have been reported already)
@tsteur commented on February 16th 2017 Owner

It looks like the document / feed you receive is misformed.

Which PHP version is that on? I presume you installed Piwik 3.0.1? It may work if you remove the "Piwik blog" widget from your dashboard.

In case you are familiar with PHP, you could debug what feed content you get by temporarily replacing

$rss = simplexml_load_string($content);

with

return htmlentities($content);
$rss = simplexml_load_string($content);

and then replacing the blog widget in your Piwik dashboard

@abolfazl-ziaratban commented on February 17th 2017

yes i installed piwik 3.0.1 .
i disabled RssWidget plugin and my problem is solved.

@tsteur commented on February 17th 2017 Owner

OK thank you for letting us know. The actual problem persists but likely related to server configuration.

This Issue was closed on February 17th 2017
Powered by GitHub Issue Mirror