@mattab opened this Pull Request on December 26th 2016 Owner

fixes #11058 correctly

For existing installations, these two fields must be manually updated to MEDIUMINT (because we are not allowed to make huge schema changes in a minor version)

@mattab commented on December 26th 2016 Owner

Actually this PR will also cause any existing Piwik install to trigger a slow schema upgrade when upgrading to 3.0.1! Not sure if we should merge it as it would trigger a slow DB migration

@mattab commented on December 26th 2016 Owner

Alternative would be:

  • do a min(value, 32767) in the tracker API to prevent mysql out of range issues
  • move this PR to PIwik 4.0
Powered by GitHub Issue Mirror