@milexjaro opened this Issue on October 26th 2016

Hi, recently, after I migrated Piwik database, and calling an API, I got this following error:

abeae3d2-ae92-461f-8020-150576d0df7d

but if the parameter "trigger=archivephp" is removed, the API works fine, how do I deal with this issue? Is there any corruptions happened during auto-archiving? Thanks

@tsteur commented on October 26th 2016 Owner

Do you have any 3rd party plugins installed? Or is it maybe possible that the "Events" plugin is disabled? You can check in "Administration => Plugins"

@milexjaro commented on October 27th 2016

"Events" plugin is already activated, and yup, I have 3rd party plugins: bottracker, advancecampaignreporting, and referrersmanager

@tsteur commented on October 27th 2016 Owner

Do you maybe see any errors in the webserver (apache / nginx )log if you have access to these? Maybe try to disable the other plugins and try to re-run it. Maybe it works then? Afterwards you can enable it again. Just to make sure it's not related to any of these plugins

@milexjaro commented on October 28th 2016

No errors were found in the log, And I have disabled the plugin, re-ran the archives, and still have the same error. So it's not related to any of these plugins I think.

@tsteur commented on October 30th 2016 Owner

Can you maybe try to update the file plugins/Actions/Archiver.php like this:

https://github.com/piwik/piwik/compare/2.x-dev...10790?quick_pull=1

It may help

@milexjaro commented on October 31st 2016

Thanks, I have done your suggestion but unfortunately, it didn't help

@milexjaro commented on October 31st 2016

So, I did the migration on 25th October 2016, and the archiving has gone wrong, if I requested the API.get method with archivephp trigger between 26th October 2016 till now, the log_link_visit_action.idaction_event_category is not detected even though it has occurred in the database

pasted image at 2016_10_31 02_21 pm

pasted image at 2016_10_31 03_21 pm

and when I requested between 25th October 2016 until now, it gave a different error like this

pasted image at 2016_10_31 02_19 pm

@tsteur commented on November 1st 2016 Owner

@milexjaro can you undo the change again? The query was wrong and falsely reported the column is missing.

I'm not really sure what the error could be and it's hard to guess. Is it maybe possible to get access to your server including database?

@mattab commented on November 3rd 2016 Owner

@milexjaro is the plugin Events activated in your piwik?

@tsteur commented on November 3rd 2016 Owner

I asked this already in first comment ;)

@milexjaro commented on November 3rd 2016

Apparently I've tried to undo the change again, and an API call from 26th October now gives the same error like from 25th October.

Sure, I will make an identical sandbox, and will notify you if the sandbox is ready, thanks

@milexjaro commented on November 5th 2016

Update: after I've tried to undo the change again, the archiving went well for 'day' period, other than that (week, month, year) didn't work at all, still have error action '11' not found.

@tsteur commented on November 6th 2016 Owner

In this case you might need to invalidate the reports for the days you experience this error and then maybe try again http://piwik.org/faq/how-to/faq_155/ The FAQ might help to invalidate reports. Otherwise a sandbox to test would be great

@mattab commented on June 19th 2017 Owner
This Issue was closed on June 19th 2017
Powered by GitHub Issue Mirror