@robocoder opened this Issue on November 29th 2009 Contributor

The current scheme has the potential for id collisions because there's no separator character between the module (plugin) name and the action (method) name, eg 'aaa' . 'bbb' == 'aa' . 'abbb'

Propose changing:

widgetVisitsSummarygetEvolutionGraph
widgetVisitorInterestgetNumberOfVisitsPerVisitDuration
widgetUserSettingsgetBrowser
... etc ...

to:

widgetVisitsSummary-getEvolutionGraph
widgetVisitorInterest-getNumberOfVisitsPerVisitDuration
widgetUserSettings-getBrowser
...
@mattab commented on March 25th 2010 Owner

won't fix for now, as collisions are likely never going to happen with the naming scheme

This Issue was closed on March 25th 2010
Powered by GitHub Issue Mirror