@anonymous-piwik-user opened this Issue on October 21st 2009

I followed the process to auto update my install today and got a nasty exception thrown.

A refresh seemed to go through OK, but def. something to look into.

(output attached)

@anonymous-piwik-user commented on October 21st 2009

Attachment: Notice: Use of undefined constant PIWIK_USER_PATH - assumed 'PIWIK_USER_PATH' in /home/webb_e/webroot/piwik.baungenjar.com/core/View.php on line 44 Backtrace -->#0 Piwik_ErrorHandler(8, Use of undefined constant PIWIK_USER_PATH - assumed 'PIWIK_USER_PATH'
Piwik_0.4.4.err

@robocoder commented on October 21st 2009 Contributor

This looks like an incomplete update.

If your tmp/latest folder contains a piwik folder, it's an indicator that the auto-update did not complete successfully. (Please check your max_execution_time in php.ini.)

Either copy tmp/latest/piwik to your root piwik folder, or download latest.zip and extract. If you re-run the installer, select "reuse existing tables".

@anonymous-piwik-user commented on October 21st 2009

The error occurred almost immediately (less than 15 seconds), so it is not an issue of exceed max_ex_time in php(set to 60 seconds on my server).

Also the tmp/latest folder does not contain a piwik folder. The update seemed to complete normally after refreshing (eg updating piwik tables, etc)

@robocoder commented on October 21st 2009 Contributor

Ok, I figured it out. The old CoreUpdater (in memory) is loading the new View.php. I think the fix is to instantiate the view earlier.

@robocoder commented on October 22nd 2009 Contributor

(re-)fixed in [& 1523

This Issue was closed on October 22nd 2009
Powered by GitHub Issue Mirror